Ne2000 nic - network unreachable, but it worked for a net install of RH62b

Ne2000 nic - network unreachable, but it worked for a net install of RH62b

Post by mnip » Sun, 31 Dec 1899 09:00:00



I have a machine (if you can call it that, parts are just strung together
loose on the table) that has a Linksys LNE2000 combo nic. I have the 10BT
port plugged into the hub, and it all worked fine for an FTP install across
my LAN of RH6.2beta.

Now I'm installed and running, but the network is unreachable. 'ping
localhost' works, but ping (my IP), nor for other IPs on the LAN. I notice
in linuxconf that the IO=0x320 and IRQ=9 are not set. When I do set them,
linuxconf says changes need to be synched, but it doesn't seem to do them.
Anyhow, whenever I go back to that adapter, linuxconf seems to have
forgotten the parameters.

my conf.modules has what appears to be an appropriate line:
options ne io=0x320 irq=9

Any ideas?

 
 
 

Ne2000 nic - network unreachable, but it worked for a net install of RH62b

Post by Johannes Richt » Sun, 31 Dec 1899 09:00:00


Hi,
look at the routing table. i had this problem too. Very often...
Greets,
Johannes Richter
--

 
 
 

Ne2000 nic - network unreachable, but it worked for a net install of RH62b

Post by mnip » Sun, 31 Dec 1899 09:00:00


What am I looking for, and which file is it? Not the hosts file, right?


Quote:> Hi,
> look at the routing table. i had this problem too. Very often...
> Greets,
> Johannes Richter
> --

 
 
 

Ne2000 nic - network unreachable, but it worked for a net install of RH62b

Post by Johannes Richt » Sun, 31 Dec 1899 09:00:00



>What am I looking for, and which file is it? Not the hosts file, right?



>> Hi,
>> look at the routing table. i had this problem too. Very often...
>> Greets,
>> Johannes Richter
>> --

look at /etc/init.d/network (under Debian, dont know under RH). Look
if the NIC is configured (ifconfig xxx.xxx.xxx.xxx netmask
255.255.255.0 broadcast xxx.xxx.xxx.255 eth0 up or similiar)
And look if there is something like route add default netmask 0.0.0.0
eth0
Good luck,
Johannes
--
 
 
 

1. RH62b net setup - NE2000 - module busy

I'm trying to get a barebones machine going with a net install of RH6.2b.
I'm having some difficulty with the NE2000 compatible NIC.

Machine is a Cyrix P166+ 48Mb of EDO, SL586VT-II motherboard. The Linksys
LNE2000 ISA combo, not in PnP mode, set to IRQ9,IO320, I9 Legacy/ISA
reserved in BIOS. The 1Gb HD has a single FAT32 partition, which I plan to
nuke with Druid during setup. Booting from the ISO's bootnet floppy image...

- boot, "expert" install
- "cancel" when asked for driver disk
-  English, US language and keyboard
- "FTP" Image (tried http too, not the problem)
- "NE1000,NE2000 and Compatible" driver choice.
- Specify parameters, io=320, irq=9, misc (blank)
- returns to "What type of image?"
  /tmp/n    busy   appears on the next line
- Retry FTP settings, this time don't spec params
- /tmp/ne.o init_module: device or resource busy.

Any ideas? I finally have an extra machine I can dedicate to linux, I'm
eager to get to it...

2. Cable Modems & Linux

3. talk not working with pl12/net-2, loopback only : network unreachable

4. Linux as a dynamic PPP router

5. Network unreachable - SLS 1.03 - NET-2

6. Problem with Chrooted Telnetd

7. Network unreachable (Slackware 1.0.4 & NET-2)

8. How to dial in to Ultra 1 from Pentium using phone line

9. Network Unreachable: net-2

10. Network unreachable, cable modem, 2 NICs

11. DSL linux net unreachable, 98 net reachable

12. ICMP Net Unreachable from... with netmasks...without it works

13. "NE2000" NIC cards and home network