pppd halts the kernel over Ositech JoD modem. Why?

pppd halts the kernel over Ositech JoD modem. Why?

Post by G. Georgie » Thu, 29 May 1997 04:00:00



Hi,

I can not understand why pppd blocks my Nec Versa 4000 laptop when i try
to execute it over the Jack of Diamonds serial card (pcmcia).

pppd works no:1 over the plip connection and when i start it from a
virtual console it prints it's 'garbage' on the console as usual.

From another side, i connect without problem with minicom over the modem
and there is nothing abnormal.

The problem is coming when I try to establish a ppp link over the same
line - 'chat' brings the line on, logs in and in the moment when pppd
starts the machine gets frozen. Only the power switch can change its
state.

Some ideas?

Thanks, George.

 
 
 

pppd halts the kernel over Ositech JoD modem. Why?

Post by G. Georgie » Thu, 29 May 1997 04:00:00


Hi,

I can not understand why pppd blocks my Nec Versa 4000 laptop when i try
to execute it over the Jack of Diamonds serial card (pcmcia).

pppd works no:1 over the plip connection and when i start it from a
virtual console it prints it's 'garbage' on the console as usual.

From another side, i connect without problem with minicom over the modem
and there is nothing abnormal.

The problem is coming when I try to establish a ppp link over the same
line - 'chat' brings the line on, logs in and in the moment when pppd
starts the machine gets frozen. Only the power switch can change its
state.

Some ideas?

Thanks, George.

 
 
 

pppd halts the kernel over Ositech JoD modem. Why?

Post by ee23.. » Sun, 01 Jun 1997 04:00:00



> Hi,

> I can not understand why pppd blocks my Nec Versa 4000 laptop when i try
> to execute it over the Jack of Diamonds serial card (pcmcia).

> pppd works no:1 over the plip connection and when i start it from a
> virtual console it prints it's 'garbage' on the console as usual.

> From another side, i connect without problem with minicom over the modem
> and there is nothing abnormal.

> The problem is coming when I try to establish a ppp link over the same
> line - 'chat' brings the line on, logs in and in the moment when pppd
> starts the machine gets frozen. Only the power switch can change its
> state.

> Some ideas?

> Thanks, George.

It sounds like you have a pppd that isn't compatible with your
kernel, since you don't have the problem until chat exits. I
recommend you get a different pppd, because it's very dependent
of the kernel used. The following are the kernel-to-pppd version dependencies:

kernel                  pppd
---------------------------------
1.2.*                   2.1.2d
1.3.0->1.3.84                "
1.3.84->1.3.99               2.2.0f
2.0.*                   "
2.1.*                   "

If the problem isn't the pppd version used, it could be that the
remote machine is using SLIP, but that's a pretty dumb
assumption anyway you look at it.

--

Posted using Reference.COM                         http://www.reference.com
Browse, Search and Post         Usenet and Mailing list Archive and Catalog.

InReference, Inc. accepts no responsibility for the content of this posting.

 
 
 

1. Ositech JoD PCMCIA eth/modem works partially. Why?

        Hi,

        For more than four months I can not put the ethernet adapter
        of my Jack of Diamonds PCMCIA card to work properly.

        Confuguration: NEC Versa 4000H, irq10, port 310, exclude
        e0000-effff runing linux 2.0.30.

        The card passes all its tests with the company supplied test
        program and recognises well the network type(10baseT),
        configures properly in linux but is unable to transmit any
        packet - the hub light for this channel does not light up,
        like if there is nothing plugged in. ifconfig says that
        packages go to the hardware, but they seem to never arrive at
        the hub.

        The modem in contrary works well, no problem from this side.

        May please give me some idea what may help to put this card
        working?

dmesg says:

Linux PCMCIA Card Services 2.8.23
Intel PCIC probe:
  Cirrus PD672x, LED, RING at 0x3e0, 2 sockets
  irq mask (Cirrus) = 0x4eb8, status change on irq 11
PCMCIA IO port probe: excluding 0x378-0x37f 0x388-0x38f 0x398-0x39f 0x3b8-0x3e7
loading device 'eth0'...
eth0: SMC91c92 at port 0x310, irq 10, 10baseT port, 00:C0:E3:10:73:25.
tty02 at 0x03e8 (irq = 10) is a 16550A

ifconfig reports:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
          UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0
          TX packets:4 errors:0 dropped:0 overruns:0

eth0      Link encap:10Mbps Ethernet  HWaddr 00:C0:E3:10:73:25
          inet addr:10.1.1.3  Bcast:10.1.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0
          TX packets:5 errors:0 dropped:0 overruns:0
          Interrupt:10 Base address:0x310

#
# Local PCMCIA Configuration File
#
# System resources available for PCMCIA devices
#
include port 0x300-0x3ff, memory 0xd0000-0xdffff
exclude port 0x000-0x2f0, memory 0xe0000-0xeffff
exclude irq 3, irq 4, irq 5, irq 6, irq 7, irq 8, irq 9, irq 12
#

                                Thanks, George.

2. character mode menu & dialog framework: summary

3. Ositech JoS modem busy?

4. Queue Message Problem with AIX 3.2

5. anyone have ositech trumpcard? (PC card ethernet/modem)

6. how can I bind two IP addr for one network card

7. dip & pppd -> modem hangs up, why?

8. Smail trouble

9. Why my pppd isn't working with Kernel 2.4.1?

10. modem, pppd, kernel EIP NULL ptr deref , RH9

11. Can anyone tell me why halt does not work in 7.2?

12. Can anyone tell me why halt does not work?

13. Why does serial I/O under X halt my machine?