Cannot login via telnet or console

Cannot login via telnet or console

Post by Danny Burche » Sun, 31 Dec 1899 09:00:00



The Redhat 6.0 box that I am using has stopped letting me log in from
the console or via telnet. I can get in via FTP so I think that means
the password is correct. Someone has tested for me and apparently SSH
login is working fine too.... anyone got any ideas. When I try and
login first I get the normal "servername login:" prompt. When username
and password are entered I get " Login incorrect" Then I get a prompt
that says "servername.domain.com login:" I normally wouldn't expect
that prompt if I had mistyoped the password, I get the first prompt
again and check my typing!

Thanks in advance for any suggestions.

Danny Burchett

 
 
 

Cannot login via telnet or console

Post by Danny Burche » Sun, 31 Dec 1899 09:00:00


Solved it.

somehow /bin/login had become corrupted. Replacing it with a working
version from another redhat install seems to have solved the problem

 
 
 

1. Can't login via xdm, but can via telnet/console

Hello Everybody.

I am haveing a problem that I think is VERY strange, I just installed linux
(RedHat Linux release 4.2 (Biltmore), Kernel 2.0.30 on a sparc) on my computer
(a sparc 1+) and I got everything set up OK (I happen to have a household
network with the following computers: Sparc IPX - Solaris 2.5.1, SGI Indigo
R3k - Iris 5.3, NeXT Color Station - OpenStep 4.1, and a couple of PCs).  I
boot the system, and everything looks good, it gets to the xdm login screen,
and when I try to login, it says "Invalid login", it does not even try to load
the session and then die , it just thinks I don't have an account, or that I
typed my password wrong.  This would be sortof easy to fix if my account was
unaccessable, but it is not, I can login through telnet, or through the
console (if I kill X).

Some more info:

I have several drives mounted via NFS (/home /tmp /var/spool/mail) but I have
tried it with them unmounted as well

As noted earlyer I am using RedHat 4.2 with kernel 2.0.30 on a SPARCstation 1+

I had it installed before, and it worked just fine, I did a reinstall because
I put in a new hard disk.

I have 2 drives, one contains / and the other contains /usr

I am useing the shadow file, but I have tried it without it as well.

I have tired connecting with another host useing xdm, and have gotten all the
way to the login screen, but still can not login.

Thanks in advance.

--
|<------------------------------------78------------------------------------>|
Benajamin A. Cooper

home.fda.net/~bacooper

If you would like to hire a sysadmin please email me for a copy of my resume.

2. Uh ... since when does an R6 Xsun suddenly work on an SX?!?

3. Login Failure in Console and via Telnet!

4. PPPD and ioctl(PPPIOCGUNIT):Operation Not Permitted

5. Console login forced via telnet

6. any Xserver for TGA on NetBSD/alpha?

7. Cannot Login from Console, Telnet - but machine works!

8. background process survive session close?

9. how do I disable telnet login with certain user id, only allowing console login?

10. Send beep to console when someone logs in via telnet

11. Console logins via modem

12. Two logins to X from one machine via virtual consoles?

13. User access Problem: Via Telnet or even console