lpd on commanline does nothing...and it's there at /usr/sbin/lpd ?

lpd on commanline does nothing...and it's there at /usr/sbin/lpd ?

Post by Tony Gonzale » Fri, 28 Mar 1997 04:00:00



I'm trying to start lpd but it won't start.   It's there
at /usr/sbin/lpd but it just won't show up with 'ps -aux'. I
have a bare bones system so there may be something missing, but
what?  Anyone know what could keep such a daemon from running?
I get no errors when I type lpd.

Thanks

-Tony

----------- here's my setup ----------

I've got filter at /var/spool/lpd/lp  and printcap at /etc

######################## printcap #################

# /etc/printcap
##PRINTTOOL## LOCAL ljet4 300x300 letter {}
lp:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :lp=/device/lp1:\
        :if=/var/spool/lpd/lp/filter:\
        :sh:

######################## filter #################

#!/bin/sh

DEVICE=ljet4
RESOLUTION=300x300
PAPERSIZE=letter
SENDEOF=

nenscript -TUS -ZB -p- |
if [ "$DEVICE" = "PostScript" ]; then
        cat -
else
        gs -q -sDEVICE=$DEVICE \
                -r$RESOLUTION \
                -sPAPERSIZE=$PAPERSIZE \
                -dNOPAUSE \
                -dSAFER \
                -sOutputFile=- -
fi

if [ "$SENDEOF" != "" ]; then
        printf "\004"
fi

exit 0

 
 
 

1. lpd on commandline does nothing...and it's there at /usr/sbin/lpd ?

I'm trying to start lpd on t commandline but it won't start.   It's there
at /usr/sbin/lpd but it just won't show up with 'ps -aux'. I
have a bare bones system so there may be something missing, but
what?  Anyone know what could keep such a daemon from running?
I get no errors when I type lpd.

Thanks

-Tony

----------- here's my setup ----------

I've got filter at /var/spool/lpd/lp  and printcap at /etc

######################## printcap #################

# /etc/printcap
##PRINTTOOL## LOCAL ljet4 300x300 letter {}
lp:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :lp=/device/lp1:\
        :if=/var/spool/lpd/lp/filter:\
        :sh:

######################## filter #################

#!/bin/sh

DEVICE=ljet4
RESOLUTION=300x300
PAPERSIZE=letter
SENDEOF=

nenscript -TUS -ZB -p- |
if [ "$DEVICE" = "PostScript" ]; then
        cat -
else
        gs -q -sDEVICE=$DEVICE \
                -r$RESOLUTION \
                -sPAPERSIZE=$PAPERSIZE \
                -dNOPAUSE \
                -dSAFER \
                -sOutputFile=- -
fi

if [ "$SENDEOF" != "" ]; then
        printf "\004"
fi

exit 0

2. Request for participation in focus group research -- small honorarium provided

3. lpd: Fatal error - Cannot bind to lpd port '515'

4. serial i/o questions

5. lpd - can't connect? lpd.perms OK?

6. copy boot disc to a replacement boot disc -

7. Linux's LPD problem... any newer lpd?

8. WEBHOSTING: $7.95/mo - NO SETUP FEE !!! YourOwnName.com, 150MB, POP3 Email... more.........

9. LPD thinks it's printing to USB but nothing happens

10. /usr/sbin/traceroute ha1 ksh: /usr/sbin/traceroute: not found

11. Can someone post lpd.conf and lpd.perm files

12. Setting up plp/lpd for lpd only

13. lpd to lpd