Netscape can't load 'libXpm.so.4'

Netscape can't load 'libXpm.so.4'

Post by Ian Pilch » Mon, 23 Jun 1997 04:00:00



Call me *ic, but I'm in the process of setting up my Linux
system "piece-by-piece".  I found that when I let Caldera's setup
program do things for me, I couldn't customize the system, because I
didn't have a clue how it was configured in the first place.

So I wiped everything out, installed a "minimum" system from the Caldera
install program, and I've been adding things piecemeal ever since.  I
just got XFree86 3.3 installed (albeit with twm), and I wanted to fire
up Netscape.  (As an aside, the rpm files on Redhat's ftp site seem
intended only to upgrade an existing installation; I had to use the
.tgz files from ftp.xfree86.org.)

I installed the Netscape rpm from my Caldera CD and tried to start it.
That's when the subject error message appeared.  I poked around a little
bit and managed to find libXpm.so.4 in the aout-lib rpm.  Unfortunately,
after installing aout-lib, Netscape still gives me the same error.  I've
verified that the path to libXpm.so.4 is in /etc/ld.so.conf, and I've
even run ldconfig manually--to no avail.

I'm a complete newbie at Linux, so I really don't know where to go from
here.  Any advice is appreciated!

Thanks!

--
========================================================================

========================================================================

 
 
 

Netscape can't load 'libXpm.so.4'

Post by Tim » Mon, 23 Jun 1997 04:00:00



> I installed the Netscape rpm from my Caldera CD and tried to start it.
> That's when the subject error message appeared.  I poked around a little
> bit and managed to find libXpm.so.4 in the aout-lib rpm.  Unfortunately,
> after installing aout-lib, Netscape still gives me the same error.  I've
> verified that the path to libXpm.so.4 is in /etc/ld.so.conf, and I've
> even run ldconfig manually--to no avail.

You don't mention what version of netscape this is, but I am assuming it is an
ELF version, which wouldn't be interested in an a.out library. Grab the ELF
version of Xpm and install that.

--
Tim Sweeney      Harborhi Consultants       Boothbay Harbor, Maine

Not valid in all 50 states.             Void where prohibited.
The contents of this post are for entertainment purposes only.          

 
 
 

Netscape can't load 'libXpm.so.4'

Post by Ian Pilche » Mon, 23 Jun 1997 04:00:00



> I installed the Netscape rpm from my Caldera CD and tried to start it.
> That's when the subject error message appeared.  I poked around a little
> bit and managed to find libXpm.so.4 in the aout-lib rpm.  Unfortunately,
> after installing aout-lib, Netscape still gives me the same error.  I've
> verified that the path to libXpm.so.4 is in /etc/ld.so.conf, and I've
> even run ldconfig manually--to no avail.

Aha!  I figured it out.  It turns out that Netscape wasn't looking for
the a.out version of libXpm.  I've installed the xpm package, which has
the ELF version of the library, and Netscape is working.

--
========================================================================

========================================================================

 
 
 

1. netscape - can't load library 'libXpm.so.4'

hi,

        i have installed slackware 3.1 (XFree86 3.2A) , everytime i try to run
netscape, i will get the following message : can't load library
'libXpm.so.4'.  i checked the /usr/X11R6/lib , the file libXpm.so.4 is
there, help!

---
Walter Lee                            

http://www.undergrad.math.uwaterloo.ca:80/~w3lee      O

2. Canon LBP-465

3. netscape: can't load library 'libXpm.so.4'

4. shell variables in AWK

5. One Machine/Multiple IP Addresses

6. Newbie startx problem: can't load library 'libXpm.so.4'

7. 'df -k' hangs

8. can't load library 'libXpm.so.4'...

9. "can't load library 'libXpm.so.4'"

10. netscape error: can't load libXpm.so.4

11. Netscape won't load libXpm.so.4

12. Netscape can't load libXpm.so.4??