LILO, DOS on /dev/hda1, LINUX /dev/hdb1

LILO, DOS on /dev/hda1, LINUX /dev/hdb1

Post by Mark A Kitchel » Mon, 30 Jan 1995 21:46:35



How must LILO be configured to successfully boot Linux, when drive
hda is totally DOS, and drive hdb is totally Linux?  If boot is from
BMR (hda), it tries to load Linux from hda -- of course it fails.  If boot
is from root Linux (hdb), it doesn't even see it (never looks);
boots straight from DOS.

There must be a parameter somewhere....



 
 
 

LILO, DOS on /dev/hda1, LINUX /dev/hdb1

Post by Duncan P Simps » Tue, 31 Jan 1995 02:20:07


What I (and probably loads of other people too...) is to install lilo
on my root partition (/dev/hda3) and then use the dos fdisk to make
partition 3 active. Now I can send the machine back into a DOs only
book just by changing the active partition. I do not want to do this
though (actually I have /dev/hdb1 all linux and am think of a 1Gb+ IDE
disc on a second control all Linux too... mess-dos will stick with that
50% full 50 Meg partition (compared with the >80% full linux ones and
amazingly only 3% file fragmentation and 11% block fragementation).

Duncan (-:

 
 
 

LILO, DOS on /dev/hda1, LINUX /dev/hdb1

Post by Steve Full » Tue, 31 Jan 1995 05:13:20



Quote:>How must LILO be configured to successfully boot Linux, when drive
>hda is totally DOS, and drive hdb is totally Linux?  If boot is from
>BMR (hda), it tries to load Linux from hda -- of course it fails.  If boot
>is from root Linux (hdb), it doesn't even see it (never looks);
>boots straight from DOS.

It sounds like you have something configured incorrectly somewhere. I'm
doing exactly what you describe above with no problems at all. Here is a
copy of my lilo.conf file:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
#compact        # faster, but won't work on all systems.
delay = 50
vga = normal    # force sane state
ramdisk = 0     # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /vmlinuz
  root = /dev/hdb1
  label = unix
# Linux bootable partition config ends
# DOS bootable partition config begins
other = /dev/hda1
  label = dos
  table = /dev/hda
# DOS bootable partition config ends

I install to the MBR on /dev/hda

Hope this helps you out

--
Steve Fuller

 
 
 

LILO, DOS on /dev/hda1, LINUX /dev/hdb1

Post by Werner Almesberg » Tue, 31 Jan 1995 06:16:37




Quote:> How must LILO be configured to successfully boot Linux, when drive
> hda is totally DOS, and drive hdb is totally Linux?

If you have a partition on hda which can hold a LILO boot sector (e.g.
an extended partition), put it there and make that partition active.

If you don't have such a partition (don't try putting the LILO boot
sector on a DOS partition !) and if you're willing to let LILO take
over your MBR, put LILO's boot sector there.

None of the above: you must either use LOADLIN or boot from floppies.

The placement of the LILO boot sector is specified with the BOOT
variable in /etc/lilo.conf. The root file system defaults to the one
that's currently mounted as root. If you're trying to install LILO
from a floppy, you typically have to mount your hard disk root FS
(e.g. under /root) and invoke LILO with
ROOT=/root /root/sbin/lilo

See also the file README that comes with LILO.

- Werner
--
  _________________________________________________________________________

 
 
 

1. copy linux from /dev/hda1 to /dev/hdb1

Hi all,

I need to create an exactly same copy of linux which is working.
Do you know how to 'copy' linux installed, for example from /dev/hda1
to /dev/hdb1?

My idea:
 % su -
 Password: ****
 % mount /dev/hdb1 /mnt/disk
 % telinit s
 % cd /
 % tar cf - bin sbin usr lib etc home var | (cd /mnt/disk; tar xf -)
 % vi /mnt/disk/etc/fstab
 % vi /etc/lilo         # add new entry for /dev/hdb1
 % lilo
 % reboot

But I don't know how to create new '/dev/*'.
Please tell me if you know it.

Regards,
kwatch

2. Slackware install hangs on PCI! Help!

3. How to transfer everything from /dev/hda1 to /dev/hdb1 ?

4. ? 100bit/s twisted pair ethernet for Linux ?

5. Lilo on /dev/hda , but /boot on /dev/hdb1

6. error while dyn. load SunOs 4.1.4

7. LILO installed on both /dev/hda AND /dev/hda1?

8. PAS SCSI and new Linux

9. LILO on /dev/hda1 booting to MBR on /dev/sda1

10. Help: can't boot dos from /dev/hdb1 using lilo

11. Help: can't boot dos on /dev/hdb1 using lilo

12. cp /dev/hda1 /dev/hbb1 to clone linux system?

13. Linux on /dev/hda1 && Win95 on /dev/hda3