par. IOmega ZIP: wrong major or minor number

par. IOmega ZIP: wrong major or minor number

Post by j.. » Sun, 31 Dec 1899 09:00:00



Hi,
Hope this is the appropriate newsgroup
I installed a parallel IOmega ZIP drive (100MB)
All but one thing went smoot

When I try to mount it
(fstab line: /dev/sda4 /ZIP vfat   noauto,user 0   0)
I get
mount /ZIP
mount: /dev/sda4 has wrong major or minor number

Some Info

 l /dev/sda4
brw-rw----   1 root     disk       8,   4 Mar 11 11:11 /dev/sda4

-------------------
 lsmod
Module                  Size  Used by
parport_probe           3492   0  (autoclean)
parport_pc              7472   1  (autoclean)
ppa                     9788   0  (unused)
parport                 7464   1  [parport_probe parport_pc ppa]    

---------------------
 cat /proc/scsi/ppa/0
Version : 2.03 (for Linux 2.2.x)
Parport : parport0
Mode    : SPP        

---------------------
 cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 06 Lun: 00
  Vendor: IOMEGA   Model: ZIP 100          Rev: D.13
  Type:   Direct-Access                    ANSI SCSI revision: 02          

---------------------------------
 grep major-8 /etc/modules.conf
alias block-major-8       sd_mod

should that be: alias block-major-8       ppa   ????

BTW
I can do fdisk /dev/sda
I can do  mkfs.msdos /dev/sda4
I can do cat /dev/sda or /dev/sda4

Can somebody give me a hint

Thanks

Jacob

 
 
 

par. IOmega ZIP: wrong major or minor number

Post by Gustin Kiffne » Sun, 31 Dec 1899 09:00:00


I think you need to 'insmod imm' - I believe that's the driver for the
iomega embedded scsi adapter.  Everything else seems right - delete
that alias lines in modules.conf until you get things working.



Quote:> Hi,
> Hope this is the appropriate newsgroup
> I installed a parallel IOmega ZIP drive (100MB)
> All but one thing went smoot

> When I try to mount it
> (fstab line: /dev/sda4 /ZIP vfat   noauto,user 0   0)
> I get
> mount /ZIP
> mount: /dev/sda4 has wrong major or minor number

> Some Info

>  l /dev/sda4
> brw-rw----   1 root     disk       8,   4 Mar 11 11:11 /dev/sda4

> -------------------
>  lsmod
> Module                  Size  Used by
> parport_probe           3492   0  (autoclean)
> parport_pc              7472   1  (autoclean)
> ppa                     9788   0  (unused)
> parport                 7464   1  [parport_probe parport_pc ppa]

> ---------------------
>  cat /proc/scsi/ppa/0
> Version : 2.03 (for Linux 2.2.x)
> Parport : parport0
> Mode    : SPP

> ---------------------
>  cat /proc/scsi/scsi
> Attached devices:
> Host: scsi0 Channel: 00 Id: 06 Lun: 00
>   Vendor: IOMEGA   Model: ZIP 100          Rev: D.13
>   Type:   Direct-Access                    ANSI SCSI revision:
02

> ---------------------------------
>  grep major-8 /etc/modules.conf
> alias block-major-8       sd_mod

> should that be: alias block-major-8       ppa   ????

> BTW
> I can do fdisk /dev/sda
> I can do  mkfs.msdos /dev/sda4
> I can do cat /dev/sda or /dev/sda4

> Can somebody give me a hint

> Thanks

> Jacob

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

par. IOmega ZIP: wrong major or minor number

Post by Christopher Broussar » Sun, 31 Dec 1899 09:00:00



> Hi,
> Hope this is the appropriate newsgroup
> I installed a parallel IOmega ZIP drive (100MB)
> All but one thing went smoot

> When I try to mount it
> (fstab line: /dev/sda4 /ZIP vfat   noauto,user 0   0)
> I get
> mount /ZIP
> mount: /dev/sda4 has wrong major or minor number

> Some Info

>  l /dev/sda4
> brw-rw----   1 root     disk       8,   4 Mar 11 11:11 /dev/sda4

> -------------------
>  lsmod
> Module                  Size  Used by
> parport_probe           3492   0  (autoclean)
> parport_pc              7472   1  (autoclean)
> ppa                     9788   0  (unused)
> parport                 7464   1  [parport_probe parport_pc ppa]

> ---------------------
>  cat /proc/scsi/ppa/0
> Version : 2.03 (for Linux 2.2.x)
> Parport : parport0
> Mode    : SPP

> ---------------------
>  cat /proc/scsi/scsi
> Attached devices:
> Host: scsi0 Channel: 00 Id: 06 Lun: 00
>   Vendor: IOMEGA   Model: ZIP 100          Rev: D.13
>   Type:   Direct-Access                    ANSI SCSI revision: 02

> ---------------------------------
>  grep major-8 /etc/modules.conf
> alias block-major-8       sd_mod

> should that be: alias block-major-8       ppa   ????

> BTW
> I can do fdisk /dev/sda
> I can do  mkfs.msdos /dev/sda4
> I can do cat /dev/sda or /dev/sda4

> Can somebody give me a hint

> Thanks

> Jacob

    Sometimes I'll get errors like that when I try to mount /dev/sda4, but
if I use /dev/sda the disk mounts fine.
 
 
 

par. IOmega ZIP: wrong major or minor number

Post by j.. » Sun, 31 Dec 1899 09:00:00




Quote:> I think you need to 'insmod imm' - I believe that's the driver for the
> iomega embedded scsi adapter.  Everything else seems right - delete
> that alias lines in modules.conf until you get things working.

Nope, I had the drive working under SuSE 6.3 and it needed the ppa-module
Only newer drives use the imm-module

Thanks for replying

Jacob

 
 
 

par. IOmega ZIP: wrong major or minor number

Post by j.. » Sun, 31 Dec 1899 09:00:00




Quote:

>     Sometimes I'll get errors like that when I try to mount /dev/sda4, but
> if I use /dev/sda the disk mounts fine.

Nope, I tried that before asking and I got
mount: /dev/sda has wrong major or minor number

Thanks for replying

Jacob

 
 
 

par. IOmega ZIP: wrong major or minor number

Post by Gustin Kiffne » Sun, 31 Dec 1899 09:00:00


What does the partition table show when you do  'fdisk /dev/sda'?
Maybe the partition numbering is off and sda4 is not the right
partition?
Or perhaps the /dev/sda4 device file really does have the wrong
major/minor number?  At any rate, the drivers you are loading are not
matching either the device you actually have or the numbers on the
device file.  I would look in the device driver source file to see what
major/minor block numbers it expects, or in
/usr/source/linux/Documentation/devices.txt for another source.



> > I think you need to 'insmod imm' - I believe that's the driver for
the
> > iomega embedded scsi adapter.  Everything else seems right - delete
> > that alias lines in modules.conf until you get things working.

> Nope, I had the drive working under SuSE 6.3 and it needed the
ppa-module
> Only newer drives use the imm-module

> Thanks for replying

> Jacob

Sent via Deja.com http://www.deja.com/
Before you buy.
 
 
 

par. IOmega ZIP: wrong major or minor number

Post by j.. » Sun, 31 Dec 1899 09:00:00




Quote:> What does the partition table show when you do  'fdisk /dev/sda'?
> Maybe the partition numbering is off and sda4 is not the right
> partition?

I got an annalogue hint in another newsgroup and the problem is solved now.

BTW, I had (on another computer) the same error message. Here
I had to recompile the kernel and put a couple of drivers (amongst others
a lowlevel scsi driver) as module rather than compiling it into the kernel.

Thanks for answering!

Jacob