Ositech JoD PCMCIA eth/modem works partially. Why?

Ositech JoD PCMCIA eth/modem works partially. Why?

Post by George Georgie » Thu, 09 Oct 1997 04:00:00



        Hi,

        For more than four months I can not put the ethernet adapter
        of my Jack of Diamonds PCMCIA card to work properly.

        Confuguration: NEC Versa 4000H, irq10, port 310, exclude
        e0000-effff runing linux 2.0.30.

        The card passes all its tests with the company supplied test
        program and recognises well the network type(10baseT),
        configures properly in linux but is unable to transmit any
        packet - the hub light for this channel does not light up,
        like if there is nothing plugged in. ifconfig says that
        packages go to the hardware, but they seem to never arrive at
        the hub.

        The modem in contrary works well, no problem from this side.

        May please give me some idea what may help to put this card
        working?

dmesg says:

Linux PCMCIA Card Services 2.8.23
Intel PCIC probe:
  Cirrus PD672x, LED, RING at 0x3e0, 2 sockets
  irq mask (Cirrus) = 0x4eb8, status change on irq 11
PCMCIA IO port probe: excluding 0x378-0x37f 0x388-0x38f 0x398-0x39f 0x3b8-0x3e7
loading device 'eth0'...
eth0: SMC91c92 at port 0x310, irq 10, 10baseT port, 00:C0:E3:10:73:25.
tty02 at 0x03e8 (irq = 10) is a 16550A

ifconfig reports:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
          UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0
          TX packets:4 errors:0 dropped:0 overruns:0

eth0      Link encap:10Mbps Ethernet  HWaddr 00:C0:E3:10:73:25
          inet addr:10.1.1.3  Bcast:10.1.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0
          TX packets:5 errors:0 dropped:0 overruns:0
          Interrupt:10 Base address:0x310

#
# Local PCMCIA Configuration File
#
# System resources available for PCMCIA devices
#
include port 0x300-0x3ff, memory 0xd0000-0xdffff
exclude port 0x000-0x2f0, memory 0xe0000-0xeffff
exclude irq 3, irq 4, irq 5, irq 6, irq 7, irq 8, irq 9, irq 12
#

                                Thanks, George.

 
 
 

Ositech JoD PCMCIA eth/modem works partially. Why?

Post by Dirk Geschk » Thu, 09 Oct 1997 04:00:00



>         For more than four months I can not put the ethernet adapter
>         of my Jack of Diamonds PCMCIA card to work properly.
>         The modem in contrary works well, no problem from this side.

>         May please give me some idea what may help to put this card
>         working?

> dmesg says:

> Linux PCMCIA Card Services 2.8.23
> Intel PCIC probe:
>   Cirrus PD672x, LED, RING at 0x3e0, 2 sockets

Since the modem card works I suspect you have a timing/velocity problem
with your PCMCIA controller

As far as I remember there are two important PCIC_OPTS entry for the
Cirrus PD672x Controller.

The first is fast_pci which should be set for busspeeds greater than
25 MHz.

The second maybe is the more important: set the commandtime to a higher
speed. This should be cmd_time=12 or cmd_time=16.

Try this options (both or at least only the last). Maybe this will solve
your problem.

You can also try the ifport command to select the transceiver type.

Dirk

 
 
 

1. Ositech Jack of D. PCMCIA eth. problem.

        Hi,

        I got a replacement the defective Jack of diamonds card I had
before, but the new one still does not want to work under linux. When I
try to mount the ethernet device it tells: 'SIOCSIFFLAGS: No such device'.
In the syslog I get 'smc91c92_cs: Yikes! Bad chip signature' and the
ethernet device doesn't show up. The card itself passes all its tests with
the company supplied program. I changed the memory window, irq and the
ports to almost every imaginable value, no difference. The computer is NEC
Versa 4080H with linux 2.0.30. Some ideas of what may correct the problem?

        The modem part works O.K., no problem from this side.

                                Thaks, George.

2. unix time

3. pppd halts the kernel over Ositech JoD modem. Why?

4. Two root file file systems ?

5. IBM "Home & Away" ETH/MODEM PCMCIA CARD

6. SLIP/PLIP Devices?

7. 3Com 3C562 PCMCIA eth+modem support?

8. Help needed on XFRM! Thanks in advance.

9. PPP and dial-out modem partially work on RS6000 AIX4.3

10. PCMCIA eth card does not work correctly, please help.

11. PCMCIA 100MBit Eth. Card doesn't work after update (Suse 8.2 -> 9.2)

12. Followup: PCMCIA 100MBit Eth. Card doesn't work after update (Suse 8.2 -> 9.2)

13. PCMCIA Grey Cell Network Card and PCMCIA Modem don't work together