iBCS and ppp problems after installing slackware 3 and making new kernal 1.3.74

iBCS and ppp problems after installing slackware 3 and making new kernal 1.3.74

Post by The Common M » Thu, 04 Apr 1996 04:00:00



First, I am new at this, but I did manage to get Slackware 3 installed
and ppp working under this version (1.2.13).  I then downloaded and
compiled a zdisk with 1.3.74, being sure to include networking and ppp
support.  Now, when I load the boot disk, I get a message that says the
iBCS module was compiled under 1.2.13 and is incompatible, and when I
try to run my ppp script, it says ppp not available.  I know I need to
recompile iBCS for 1.3.74, but I can't find the source code (on my
system, and yes, I looked real hard) and I really don't know how.  I
have no idea how I biffed the ppp stuff.  Can someone steer me in the
right direction here, either to a document that explains this or giving
me instructions on how to rectify the problem?  Thank you.

A brand-newbie,
Michael


 
 
 

iBCS and ppp problems after installing slackware 3 and making new kernal 1.3.74

Post by Reg Burge » Fri, 05 Apr 1996 04:00:00


On the infomagic sets the source is there.  Basically you move a .tar.gz  
file into a new empty directory, unpack it with tar using something like  
tar xfvz ibcs_somedate.tar.gz  that creates a /ibcs sub-dir that you then  
cd into.  Do ls and you'll see a Makefile  run make  -  just type  make
Unfortunately it throws up tons of seemingly innocent warnings and finally  
gets to an error condition which is fatal.  Something about not being able  
to find a file called crt0.  There is a file called crt1 in that sub-dir,  
FWIW.

Thats about all I know - I guess the message is don't waste time  
re-compiling unless you are able to de-bug the Makefile.

Reg     {probably backing off to earlier distributions for a while}

========================================================================

Common Man) writes:
> First, I am new at this, but I did manage to get Slackware 3 installed
> and ppp working under this version (1.2.13).  I then downloaded and
> compiled a zdisk with 1.3.74, being sure to include networking and ppp
> support.  Now, when I load the boot disk, I get a message that says the
> iBCS module was compiled under 1.2.13 and is incompatible, and when I
> try to run my ppp script, it says ppp not available.  I know I need to
> recompile iBCS for 1.3.74, but I can't find the source code (on my
> system, and yes, I looked real hard) and I really don't know how.  I
> have no idea how I biffed the ppp stuff.  Can someone steer me in the
> right direction here, either to a document that explains this or giving
> me instructions on how to rectify the problem?  Thank you.

> A brand-newbie,
> Michael