netscape: can't load library 'libXpm.so.4'

netscape: can't load library 'libXpm.so.4'

Post by (Cybiades) Peter » Fri, 20 Nov 1998 04:00:00




> after installing netscape communicator 4.5 from:
> 'communicator-v45-us.x86-unknown-linux2.0.tar.gz'

> When I try to run netscape I get error:
> can't load library 'libXpm.so.4'

> I found related posts on dejanews that talked about needing libc5
> library.  Being new to Linux, I really don't know how to proceed.
> Could someone help me understand:
> 1) what these libraries are
> 2) where do I get them
> 3) how do I install them
> 4) will doing so mess up anything else on my system

> Thanks in advance
> I don't know how I would learn this stuff without newsgroups!

> Reagan Doose

Hi!

You might want to try http://rufus.w3.org Among this site, you'll find
the ability to look up a util/lib by name and it will tell you what it
is dependent on, what it's included in, etc...all of rufus' files are in
rpm format, so you'll need to have rpm installed before you can unpack
the files.
'Later
Peter

--
Cybiades: Computing For Fun
http://www.ticnet.com/azenomei/fels/fels.html
Visit my online world!!! (In progress)
Running Linux 2.0.35
AfterStep FAQ http://www.ticnet.com/azenomei/as/start.html

 
 
 

netscape: can't load library 'libXpm.so.4'

Post by Reagan Doo » Sat, 21 Nov 1998 04:00:00


after installing netscape communicator 4.5 from:
'communicator-v45-us.x86-unknown-linux2.0.tar.gz'

When I try to run netscape I get error:
can't load library 'libXpm.so.4'

I found related posts on dejanews that talked about needing libc5
library.  Being new to Linux, I really don't know how to proceed.
Could someone help me understand:
1) what these libraries are
2) where do I get them
3) how do I install them
4) will doing so mess up anything else on my system

Thanks in advance
I don't know how I would learn this stuff without newsgroups!

Reagan Doose

 
 
 

netscape: can't load library 'libXpm.so.4'

Post by Eric Pott » Sat, 21 Nov 1998 04:00:00


[Posted and mailed]

Reagan Doose enlightened this group thus:

Quote:> after installing netscape communicator 4.5 from:
> 'communicator-v45-us.x86-unknown-linux2.0.tar.gz'

If you are running a glibc2 based system (i.e. redhat 5.x) then you want to get
the glibc2 based version of netscape.  I believe they keep it in the unsupported
directory on the netscape ftp site.

Quote:> When I try to run netscape I get error:
> can't load library 'libXpm.so.4'

See if you have it:
find / -name "libXpm.so*" -print
If you do have it, then getting the correct version of netscape should solve
the problem.  If you don't have it, then just download the .rpm from redhat.
The name of the file is xpm-3.4j-2.rpm

Quote:

> I found related posts on dejanews that talked about needing libc5
> library.  Being new to Linux, I really don't know how to proceed.

First we need to know which version of linux you are running.

Quote:> Could someone help me understand:
> 1) what these libraries are

These are dynamically loaded shared libraries.

Quote:> 2) where do I get them

It's probably on your distribution cdrom.  Or  get it from an ftp site.

Quote:> 3) how do I install them

Depends on the distribution.

Quote:> 4) will doing so mess up anything else on my system

Probably not in the case of libXpm.

Quote:> Thanks in advance
> I don't know how I would learn this stuff without newsgroups!

> Reagan Doose

--

 *^  / \  \   |  \       When replying to me,  remove the NOSPAM
 / \/   \  \__|   \      from my address.
/  /   ^ \  \    
  /       \  \           Eric Potter
 /  ^   ^  \  \          
 
 
 

netscape: can't load library 'libXpm.so.4'

Post by ro » Sat, 21 Nov 1998 04:00:00


On Thu, 19 Nov 1998 22:47:53 -0600, "(Cybiades) Peter B"



>> after installing netscape communicator 4.5 from:
>> 'communicator-v45-us.x86-unknown-linux2.0.tar.gz'

>> When I try to run netscape I get error:
>> can't load library 'libXpm.so.4'

What you really need is libXpm-4.7  usually is found on every
distribution disk.  
 
 
 

1. netscape - can't load library 'libXpm.so.4'

hi,

        i have installed slackware 3.1 (XFree86 3.2A) , everytime i try to run
netscape, i will get the following message : can't load library
'libXpm.so.4'.  i checked the /usr/X11R6/lib , the file libXpm.so.4 is
there, help!

---
Walter Lee                            

http://www.undergrad.math.uwaterloo.ca:80/~w3lee      O

2. lm8.2,kde3 after upgrade boots to kde2 instead, didnt overlap

3. netscape: can't load library 'libXpm.so.4'

4. Linux firewall able to filter by mac addresses ?

5. Newbie startx problem: can't load library 'libXpm.so.4'

6. 2.4.20: ideN=... option stopped working

7. can't load library 'libXpm.so.4'...

8. solaris 2.1 (86) disk access blues

9. "can't load library 'libXpm.so.4'"

10. Netscape can't load 'libXpm.so.4'

11. Can't load library libXpm.so.4 with netscape

12. Java can't load library libXpm.so.4

13. netscape error: can't load libXpm.so.4