3Com Etherlink III and Win95 with PnP disabled- Dillema!

3Com Etherlink III and Win95 with PnP disabled- Dillema!

Post by Eric Sand » Fri, 13 Feb 1998 04:00:00



I'm experiencing a problem with my 3Com Etherlink (3c509B) NIC running under
both Win95 and RedHat Linux 5.0 (dual boot system). Here's the deal. Linux
won't recognize the card if its PROM has Plug n Play enabled. However, when I
disable PnP, then Win95 won't recognize the card. My question is this:

Is there a way to run the NIC under Win95 without having PnP enabled?

When I remove the 3Com Etherlink PnP drivers from within Win95 networking
properties, and the select "Add", I don't see any drivers that support the NIC
WITHOUT pnp.

Below is my config:
Dell p120
Win95a
RedHat Linux 5.0 - Using LILO Boot Manager
3Com EtherLink III ISA (3c509b) NIC


Eric Sands

 
 
 

3Com Etherlink III and Win95 with PnP disabled- Dillema!

Post by Peter Sentve » Sat, 14 Feb 1998 04:00:00


I had the same problem but it was easy to solve.
If in pnp mode win95 loads the pnp driver. If you delete that driver
and add the Etherlink ISA mode driver it should work. (it's working
here)

Good luck
        Peter



>I'm experiencing a problem with my 3Com Etherlink (3c509B) NIC running under
>both Win95 and RedHat Linux 5.0 (dual boot system). Here's the deal. Linux
>won't recognize the card if its PROM has Plug n Play enabled. However, when I
>disable PnP, then Win95 won't recognize the card. My question is this:

>Is there a way to run the NIC under Win95 without having PnP enabled?

>When I remove the 3Com Etherlink PnP drivers from within Win95 networking
>properties, and the select "Add", I don't see any drivers that support the NIC
>WITHOUT pnp.

>Below is my config:
>Dell p120
>Win95a
>RedHat Linux 5.0 - Using LILO Boot Manager
>3Com EtherLink III ISA (3c509b) NIC


>Eric Sands


 
 
 

3Com Etherlink III and Win95 with PnP disabled- Dillema!

Post by Luke » Mon, 16 Feb 1998 04:00:00


If Im correct.. I believe I have the same card <3com 509b, the guy that does
PNP..> I have PNP compleatly disabled... if you use detect new hardware.. it
should show up.. Ive used this card on win95 upgrade, win95 OEM 1,  win95
OEM2 and on a lot of the win98 betas... Linux does have PNP tools that you
can use <or at least in the newer slackware versions> And I know you can
download the right tools to get the card working as long as you use
dos/windows to set the icq/io..... to the right config it should work
allright. I am also using a generic realtek card <uses ne2000 driver> that
configures it self .. kinda a pain in the *if I change the cards around
because it will some times change its own addresses.. ekky.. :) Anyhow, If
you still card get the card working in windows without PNP <after doing a
actuall hardware detect from the control panal.. -add hardware thing> try
getting updated drivers from there site.
Luke

 
 
 

1. About PNP mode of 3Com Etherlink III ISA (3C509b-TP)

Hi, there,

I have tried to install RedHat 4.2 using FTP.  However, somehow,
it cannot detect my network card - 3Com Etherlink III ISA (3C509b-TP).
Is there anyway to disable the PNP mode and force the boot disk
to find the card?  If not, what's the best way to install it.  Should
I install linux from CD first and then configure my kernel to find the
network card?

Any hints or suggestions will be appreciated.  Thank you.

zjl


2. Mail robot?

3. 3Com Etherlink III ( 509B )

4. Ultra5: Disable front speaker & use rear ports

5. 3COM Etherlink III MCA/7006

6. Problem with Netscape 4.7 and a single frame construction

7. 3Com 3c509 (Etherlink III) drivers

8. Linking Libraries

9. HELP: Driver for 3com Etherlink III needed

10. 3Com Etherlink III (3c509)-- TP bug?

11. 3Com 3c589C Etherlink III PCMCIA problems

12. Two or more 3com Etherlink III adapters with openBSD 2.9 don't work???

13. Problem with EMM386 and 3com etherlink III