Can't mount Floppy or Cdrom

Can't mount Floppy or Cdrom

Post by subun » Fri, 09 Feb 2001 12:51:41



I can't seem to mount my floppy drive or my cdrom drive.  I was able to
before and am now having a problem.  I am tring to go throught and
Armour my box so I may have messed something up.  I have an /etc/fstab
file in place and it says that I have dev=/dev/fd0 and dev=/dev/cdrom
and it says that they are supermount.  I also checked my /mount
directory and those directories are there.  when I try to 'cd' to
/floppy or /cdrom the terminal locks up.  I can alt+F2 to get a new
login so it dosen't lock up the whole system.  I have tried to mount as
root and as a normal user and get the same results.  I am having some
strange messages when I 'su' from root to a user account.  I am able to
do so but I get a message that says bash: /dev/tty2: Permission denied.
Then when I sometimes get 'ls' the directory I get ls: .: Permission
denied.  When I looked in the /var/messages file I see a message that
says 'end_request_: I/O Error, dev 02:00 (floppy) sector 0 .  When I go
to /dev and try to 'cat fd0' I get the message back 'device not
configured'.  Any help would be appriciated as I am tiring of fixing
problems more than learning how to use Linux. Yes this is also a lesson
for me to start backing up files before I make changes.

Thanks,
subuno

 
 
 

Can't mount Floppy or Cdrom

Post by Eric » Fri, 09 Feb 2001 18:30:41



> I can't seem to mount my floppy drive or my cdrom drive.  I was able to
> before and am now having a problem.  I am tring to go throught and
> Armour my box so I may have messed something up.  I have an /etc/fstab
> file in place and it says that I have dev=/dev/fd0 and dev=/dev/cdrom
> and it says that they are supermount.  I also checked my /mount
> directory and those directories are there.  when I try to 'cd' to
> /floppy or /cdrom the terminal locks up.  I can alt+F2 to get a new
> login so it dosen't lock up the whole system.  I have tried to mount as
> root and as a normal user and get the same results.  I am having some
> strange messages when I 'su' from root to a user account.  I am able to
> do so but I get a message that says bash: /dev/tty2: Permission denied.
> Then when I sometimes get 'ls' the directory I get ls: .: Permission
> denied.  When I looked in the /var/messages file I see a message that
> says 'end_request_: I/O Error, dev 02:00 (floppy) sector 0 .  When I go
> to /dev and try to 'cat fd0' I get the message back 'device not
> configured'.  Any help would be appriciated as I am tiring of fixing
> problems more than learning how to use Linux. Yes this is also a lesson
> for me to start backing up files before I make changes.

Sounds like the /dev/ directory is messed up.
What entries do you have for floppy/cdrom/tty* etc

Eric

 
 
 

1. Can't mount cdrom or floppy.

Thanks for the response Eric.  For some reason my messages keep
diapearing before I can answer them.  I no longer have a /dev directory
becuase I deleted the Linux partition and am going to start over again
with RedHat 7 I think.

Thanks again,
subuno

2. Log File of ALL keyboard input

3. can't mount floppy+cdrom

4. locate.updatedb problem

5. Newbie - File System Manager won't mount cdrom/floppy

6. remote backup via ftp...

7. sol 2.5 x86 won't mount cdrom or floppy

8. PPP problems with RH6.0

9. Mount a floppy,Cdrom etc...I'm newbies Help !!!

10. User can't mount CDROM & Floppy

11. Cant'mount my cdroms of floppy

12. Mount a floppy, Cdrom etc...I'm newbies...Help!!!!