RH 5.0 rpms usable under RH 4.2?

RH 5.0 rpms usable under RH 4.2?

Post by William Richte » Sun, 11 Jan 1998 04:00:00



I'm using RH 4.2, and I downloaded some RH 5.0 rpm files from
ftp.redhat.com://pub/redhat/redhat-5.0/i386/RedHat/RPMS, and I just
went round in circles.  Should I conclude that I must install RH 5.0
before I can use any of these rpm files?  The rpm files in the
directory /pub/redhat/redhat-4.2/updates/i386 seem to work fine:

[root]# rpm -Uhv XFree86-3.3.1-1.i386.rpm
XFree86
##################################################

Here's my abortive transcript with the 5.0 rpm files:

[root]# rpm -Uhv XFree86-3.3.1-14.i386.rpm
failed dependencies:
        /bin/sh is needed by XFree86-3.3.1-14
        /bin/bash is needed by XFree86-3.3.1-14
        libm.so.6 is needed by XFree86-3.3.1-14
        libdl.so.2 is needed by XFree86-3.3.1-14
        libcrypt.so.1 is needed by XFree86-3.3.1-14
        libc.so.6 is needed by XFree86-3.3.1-14
        ld-linux.so.2 is needed by XFree86-3.3.1-14
        pam >= 0.59 is needed by XFree86-3.3.1-14

[root]# rpm -Uhv libc-5.3.12-24.i386.rpm
failed dependencies:
        /bin/sh   is needed by libc-5.3.12-24
        /lib/ld-linux.so.1 is needed by libc-5.3.12-24
        fileutils   is needed by libc-5.3.12-24
        grep   is needed by libc-5.3.12-24
        /sbin/ldconfig   is needed by libc-5.3.12-24

[root]# rpm -Uhv grep-2.1-1.i386.rpm
failed dependencies:
        libc.so.6 is needed by grep-2.1-1
        ld-linux.so.2 is needed by grep-2.1-1

[root]# rpm -Uhv fileutils-3.16-6.i386.rpm
failed dependencies:
        libc.so.6 is needed by fileutils-3.16-6
        ld-linux.so.2 is needed by fileutils-3.16-6

[root]# rpm -Uhv ld.so-1.9.5-5.i386.rpm
failed dependencies:
        filesystem   is needed by ld.so-1.9.5-5

[root]# rpm -Uhv filesystem-1.3.1-2.noarch.rpm
failed dependencies:
        setup   is needed by filesystem-1.3.1-2

[root]# rpm -Uhv setup-1.9-2.noarch.rpm
package setup-1.9-2 is for a different architecture
error: setup-1.9-2.noarch.rpm cannot be installed

[root]# rpm -Uhv setuptool-1.0-1.noarch.rpm
failed dependencies:
        /usr/bin/python is needed by setuptool-1.0-1
        snack is needed by setuptool-1.0-1
        pythonlib >= 1.21 is needed by setuptool-1.0-1

[root]# rpm -Uhv python-1.4-9.i386.rpm
failed dependencies:
        /usr/bin/python is needed by python-1.4-9
        /bin/sh is needed by python-1.4-9
        libreadline.so.3 is needed by python-1.4-9
        libm.so.6 is needed by python-1.4-9
        libdl.so.2 is needed by python-1.4-9
        libc.so.6 is needed by python-1.4-9
        ld-linux.so.2 is needed by python-1.4-9

[root]# rpm -Uhv pam-0.59-5.i386.rpm
failed dependencies:
        libnsl.so.1 is needed by pam-0.59-5
        libcrypt.so.1 is needed by pam-0.59-5
        libc.so.6 is needed by pam-0.59-5
        ld-linux.so.2 is needed by pam-0.59-5
        /bin/sh   is needed by pam-0.59-5

I don't even know what libcrypt, libnsl.so and snack are, I don't
think they weren't on the RH 4.2 CD-ROM.

 
 
 

RH 5.0 rpms usable under RH 4.2?

Post by Tom Gravgaard Christens » Sat, 17 Jan 1998 04:00:00


On 10 Jan 1998 04:01:16 -0500, William Richter


>I'm using RH 4.2, and I downloaded some RH 5.0 rpm files from
>ftp.redhat.com://pub/redhat/redhat-5.0/i386/RedHat/RPMS, and I just
>went round in circles.  Should I conclude that I must install RH 5.0
>before I can use any of these rpm files?  The rpm files in the
>directory /pub/redhat/redhat-4.2/updates/i386 seem to work fine:

<snip lots of rpm errors>
Using RH5 RPM's with RH4.2 (and earlier) is at best problematic, at
worst impossible.
The problem is that with RH5 also came a change in the major number of
libc. This means that all the RPM's shipped with RH5 is compiled
against libc6. These will only work if you already installed
glibc2/libc6 onto your existing RH system.
I don't know if there's any RPM's available containing just glibc2?
If there's not and you really wan't to use these RPM's just get
glibc-2.0.6.tar.gz from your nearest GNU mirror. When you have read
the accompanying docs. Then go here to see step-by-step instructions
on how to do the install:
www.imaxx.net/~thrytis/glibc/

--
Tom G. Christensen, Denmark
tom dot christensen at get2net dot dk

 
 
 

1. RH 4.2 -> RH 5.0

I have a mostly stock RH 4.2 system, and I now have a 5.0 CD-ROM.

Step 1: Try to do a complete new install onto an unused partition.  Create
boot image.  Start up.  First screen (claim I am novice, just hit enter).
Kernel starts, does a couple of things and then dies at
        "CANNOT OPEN ROOT DEVICE 08:05"
which is odd given that the root device is supposed to be the IDE CD-ROM
drive.  (there are a couple of scsi disks onto which I want to install, but
they are not supposed to be the root device).

Step 2: Try to upgrade the present system.  Go to
        /mnt/cdrom/Redhat/RPMS/
and do a
        rpm -i -U *rpm
Tons of errors about such things as missing shells.

Either of these methods would be fine with me, if I could just get it to
work.  Any ideas?

/ivo welch
--

UCLA            http://linux.agsm.ucla.edu/
*** International Directory of Financial Economists ***
        http://linux.agsm.ucla.edu/dir/

2. SMP problem with P

3. SMBFS-2.0.2 on RH 5.0 (was Re: make error on RH 5.0)

4. Hanging on autoprobe

5. Strange experience going RH 4.0 --> RH 4.2

6. Tape drive on || port

7. Can a pgm compiled on RH 5.1 run on RH 4.2?

8. Where is Radiance ?

9. Problem with scripts that work on RH 4.2 but not RH 5.2

10. RH 3.0.3 -> RH 4.2 CD Missing File?

11. How painful is it to upgrade from RH 4.2 to RH 6.1?

12. XF86Config oddity RH 4.2 -> Rh 5.1

13. Login: RH 5.1 Slower than RH 4.2