Expect/Tcl Problem - "scripts expect Tcl version..."

Expect/Tcl Problem - "scripts expect Tcl version..."

Post by Jim Bianc » Thu, 16 Jul 1998 04:00:00




>Hi ALL!!!!

>I have installed the the last version of Tcl/Tl  (8.0) and the binaries of
>expect 5.18, but I can't make expect work!!!

>Every time I execute "expect" it says:

>Tcl_Init failed: version mismatch: library
>scripts expect Tcl version 7.5b1 or later but the loaded version is
>only 7.4

        Ok. I installed expect and the libraries it wants and had no
problems at all. I forget exactly what it was I did, but I think there's a
cmd that will put the newly installed library name in a database somewhere.
It's called mklibdir or somesuch. What apparantly happens is any app that
needs a particular library will look at this database 1) to determine if the
library exists and 2) to find where it is. If the library is not in this
database, the app will fail step #1 and will exit, complaining 'lib xxxx'
is missing.

        You need to run this as root and you need to run this cmd each time
you install a new library(s), else the apps that use those libraries will
never be able to find them.

        The same thing applies to mkfontdir and new fonts.

--

Eclectic Garbanzo BBS, (707) 539-1279