getting lilo to work with copy of working install on other partition

getting lilo to work with copy of working install on other partition

Post by Erik » Tue, 29 Apr 2003 08:58:08



Hi people,

I copied my mdk 9.1 installation from an ext3 to an reiserfs partition.
The problem I now have is that I'm not able to start the installation on
the reiserfs. I don't know how to change lilo to start it.

I now have lilo on the MBR to start the ext3 installation on hda7. What
I want is to add another lilo on the reiserfs partition on hda8. How can
I add this lilo on hda8 from within the running ext3 installation on
hda7? My problem is that I can only seem to install lilo based on the
kernel and initrd on the ext3 installation on hda7.

Another option for me would be to somehow start the reiserfs
installation and run lilo from there. But I have no clue on how to start
that. Any suggestions?

Thanks,
Erik

 
 
 

getting lilo to work with copy of working install on other partition

Post by Bit Twiste » Tue, 29 Apr 2003 09:11:57



> Hi people,

> I copied my mdk 9.1 installation from an ext3 to an reiserfs partition.
> The problem I now have is that I'm not able to start the installation on
> the reiserfs. I don't know how to change lilo to start it.

> I now have lilo on the MBR to start the ext3 installation on hda7. What
> I want is to add another lilo on the reiserfs partition on hda8. How can
> I add this lilo on hda8 from within the running ext3 installation on
> hda7? My problem is that I can only seem to install lilo based on the
> kernel and initrd on the ext3 installation on hda7.

> Another option for me would be to somehow start the reiserfs
> installation and run lilo from there. But I have no clue on how to start
> that. Any suggestions?

add a new standza to
      /etc/lilo.conf
create a mount point, mount the hda8 partition
and do a
      lilo -v

Here is an example of dual booting release 9.0 and 9.1 mandrake
I created the /md91n mount point and entered it in my /etc/fstab
In this setup 91 is on the slave drive.

image=/boot/vmlinuz
        label="linux"
        root=/dev/hda1
        initrd=/boot/initrd-2.4.21-0.13mdk.img
        append="acpi=off"
        read-only
image=/md91n/boot/vmlinuz
        label="n91"
        root=/dev/hdb5
        initrd=/md91n/boot/initrd.img
        append="acpi=off"
        read-only

 
 
 

getting lilo to work with copy of working install on other partition

Post by Davi » Tue, 29 Apr 2003 15:32:41




>>Hi people,

>>I copied my mdk 9.1 installation from an ext3 to an reiserfs partition.
>>The problem I now have is that I'm not able to start the installation on
>>the reiserfs. I don't know how to change lilo to start it.

>>I now have lilo on the MBR to start the ext3 installation on hda7. What
>>I want is to add another lilo on the reiserfs partition on hda8. How can
>>I add this lilo on hda8 from within the running ext3 installation on
>>hda7? My problem is that I can only seem to install lilo based on the
>>kernel and initrd on the ext3 installation on hda7.

>>Another option for me would be to somehow start the reiserfs
>>installation and run lilo from there. But I have no clue on how to start
>>that. Any suggestions?

If you copied it to a new partition then you need to edit
/etc/fstab so it mounts the partitions using the right filesystem
format.

--
Confucius:  He who play in root, eventually kill tree.
Registered with the Linux Counter.  http://counter.li.org
Slackware 9.0 Kernel 2.4.20 i686 (GCC) 3.2.2
Uptime: 23 days, 24 min, 1 user, load average: 1.17, 1.19, 1.19