new kernel + LILO = bad stuff

new kernel + LILO = bad stuff

Post by Brian L. Naylo » Wed, 15 Nov 1995 04:00:00



   I recompiled my kernel (1.2.13) to suit my tastes (I've done
this before without problems) and reran LILO, but when I try to
boot my Linux partition, "LILO Loading Linux...." repeats over
and over, without ever booting.

   My old kernel still works, if I run LILO on it, and the new one
works fine from floppy.  I noticed that rdev /vmlinuz on the new
kernel reported "Boot device" as the root device while on the old
kernel, it says "/dev/hda4".  I used rdev to change this value on
my new kernel, to no avail.

   This is a quandary.  Please, does anyone have any suggestions?
     (It's done this on two totally different systems, now!)

Thanks,
Brian Naylor

 
 
 

new kernel + LILO = bad stuff

Post by Rick Daugher » Fri, 17 Nov 1995 04:00:00



says...

Quote:

>   I recompiled my kernel (1.2.13) to suit my tastes (I've done
>this before without problems) and reran LILO, but when I try to
>boot my Linux partition, "LILO Loading Linux...." repeats over
>and over, without ever booting.

>Thanks,
>Brian Naylor

Brian,

I had the same problem, once. I think I was using the kernel image that resides
in arch/i386/boot/compressed after build - vmlinux. I copied it to /vmlinuz
and then ran /etc/lilo/install. I had the same results, repeating "....." This
was NOT the right image to be using. The correct image was zImage, imagine that
:) (make zImage). Anyway, I have other problems but the kernel does boot...

Hope this helps,



 
 
 

1. new sound stuff in new kernels ?

Can someone tell me what new aspects to sound support have been added to the latest
kernels (higher than 1.3.90) ? I've heard that there's now a /dev/dsp16 which will
automatically recognize and play 16-bit 44.1 kHz .wav files. If so, that could be
good news to those of us running realtime Csound (as of now I'm having to settle
for 8-bit u-law soundfiles, but at least I'm getting realtime synthesis from a
486/120).

== Dave Phillips

           My Web pages, back at last:
    http://www.bright.net/~dlphilp/index.html

        Quare id faciam fortasse requiris:
      Nescio, sed fieri sentio et excrucior.

2. Msyslog alerts

3. Good stuff Bad Stuff

4. Video Setup

5. Bad stuff happening; can't add new users, change passwords, etc

6. Dot Clocks With ATI Ultra+

7. new kernel: LILO "kernel too big" error

8. Problem during installation. Please help!

9. I need a new kernel, but hd is stuff'd...