SB-Pro on 1.2.13: write error: I/O error

SB-Pro on 1.2.13: write error: I/O error

Post by Paul Gre » Thu, 10 Jul 1997 04:00:00



Summary:  I've added a SBPro card into my historic 1.2.13 linux system.
I can't upgrade the kernel to 2.x as I'm running too much on the box that I'm
afraid of breaking.
The card will play a sound/file for 1 second before crashing out with
cat: write error: I/O error. - This doesn't seem to be covered by Sound
Howto FAQ 6.10.

I've remade my kernel (1.2.13), etc, and the card is recognised fine. All
/dev/ files seem to be installed fine.
But when I try to test it:

eebau:pgregg/p4-~/tmp/sndkit/dsp-2%->cat endoftheworld >/dev/dsp         2:56pm
cat: write error: I/O error

and

eebau:pgregg/p4-/u3/ftp/private/stephen/auteurs/sounds-5%->cat buddha.au >/dev/a
udio
cat: write error: I/O error

I can hear approximately one second of sound before the error appears.

The closest FAQ I can find is 6.10, but as you can see the error message
is an I/O error and not IRQ or DMA timeout.

Any advice is appreciated.

Regards,

Paul Gregg

Supplimentary info below.

eebau:pgregg/pa-~/tmp/sndkit/dsp-1%->ls -la /dev/dsp /dev/audio          2:49pm
crw-rw-rw-   1 root     root      14,   4 Jul  9 14:17 /dev/audio
crw-rw-rw-   1 root     root      14,   3 Jul  9 14:17 /dev/dsp

eebau:pgregg/pa-~/tmp/sndkit/dsp-2%->cat /dev/sndstat                    3:03pm

Config options: 35c02

Installed drivers:
Type 1: OPL-2/OPL-3 FM
Type 2: SoundBlaster
Type 6: SoundBlaster16
Type 7: SB16 MIDI

Card config:
SoundBlaster at 0x220 irq 9 drq 1
SoundBlaster16 at 0x220 irq 9 drq 6
(SB16 MIDI at 0x330 irq 9 drq 0)
OPL-2/OPL-3 FM at 0x388 irq 0 drq 0

PCM devices:
0: SoundBlaster 16 4.13

Synth devices:
0: Yamaha OPL-3

Midi devices:

MIDI Timers:
0: System Timer

1 mixer(s) installed

eebau:pgregg/pa-~/tmp/sndkit/dsp-3%->cat /proc/devices                   3:03pm
Character devices:
 1 mem
 4 ttyp
 5 cua
 6 lp
 7 vcs
10 mouse
14 sound
21 sg

Block devices:
 2 fd
 8 sd

eebau:pgregg/pa-~/tmp/sndkit/dsp-4%->uname -a                            3:04pm
Linux eebau 1.2.13 #17 Wed Jul 9 13:43:39 GMT 1997 i586

--
 The Internet Business Ltd, Holywood House, Innis Court, Holywood, BT18 9HF

            Phone: +44 (0)1232-424190  Fax: +44 (0)1232-424709
           Eight out of every five people are math illiterates.

 
 
 

1. SB-Pro on 1.2.13: write error: I/O error

Summary:  I've added a SBPro card into my historic 1.2.13 linux system.
I can't upgrade the kernel to 2.x as I'm running too much on the box that I'm
afraid of breaking.
The card will play a sound/file for 1 second before crashing out with
cat: write error: I/O error. - This doesn't seem to be covered by Sound
Howto FAQ 6.10.

I've remade my kernel (1.2.13), etc, and the card is recognised fine. All
/dev/ files seem to be installed fine.
But when I try to test it:

eebau:pgregg/p4-~/tmp/sndkit/dsp-2%->cat endoftheworld >/dev/dsp         2:56pm
cat: write error: I/O error

and

eebau:pgregg/p4-/u3/ftp/private/stephen/auteurs/sounds-5%->cat buddha.au >/dev/a
udio
cat: write error: I/O error

I can hear approximately one second of sound before the error appears.

The closest FAQ I can find is 6.10, but as you can see the error message
is an I/O error and not IRQ or DMA timeout.

Any advice is appreciated.

Regards,

Paul Gregg

Supplimentary info below.

eebau:pgregg/pa-~/tmp/sndkit/dsp-1%->ls -la /dev/dsp /dev/audio          2:49pm
crw-rw-rw-   1 root     root      14,   4 Jul  9 14:17 /dev/audio
crw-rw-rw-   1 root     root      14,   3 Jul  9 14:17 /dev/dsp

eebau:pgregg/pa-~/tmp/sndkit/dsp-2%->cat /dev/sndstat                    3:03pm

Config options: 35c02

Installed drivers:
Type 1: OPL-2/OPL-3 FM
Type 2: SoundBlaster
Type 6: SoundBlaster16
Type 7: SB16 MIDI

Card config:
SoundBlaster at 0x220 irq 9 drq 1
SoundBlaster16 at 0x220 irq 9 drq 6
(SB16 MIDI at 0x330 irq 9 drq 0)
OPL-2/OPL-3 FM at 0x388 irq 0 drq 0

PCM devices:
0: SoundBlaster 16 4.13

Synth devices:
0: Yamaha OPL-3

Midi devices:

MIDI Timers:
0: System Timer

1 mixer(s) installed

eebau:pgregg/pa-~/tmp/sndkit/dsp-3%->cat /proc/devices                   3:03pm
Character devices:
 1 mem
 4 ttyp
 5 cua
 6 lp
 7 vcs
10 mouse
14 sound
21 sg

Block devices:
2 fd
 8 sd

eebau:pgregg/pa-~/tmp/sndkit/dsp-4%->uname -a                            3:04pm
Linux eebau 1.2.13 #17 Wed Jul 9 13:43:39 GMT 1997 i586

--
 The Internet Business Ltd, Holywood House, Innis Court, Holywood, BT18 9HF

            Phone: +44 (0)1232-424190  Fax: +44 (0)1232-424709
           Eight out of every five people are math illiterates.

2. xiafs / ext2fs mkfs/fsck trouble

3. strange problems 1.2.13 --> 2.0.0 --> 1.2.13

4. Reiserfs vs rpm wierdness

5. DIP: Error following kernel re-compilation (v 1.2.13)

6. booting AIX on 7012-340 from CD

7. errors compiling 1.2.13 ELF

8. How to check the number of "user processes" in the system?

9. GCC, 1.2.13 and _xstat link errors

10. iBCS module error between kernel 1.2.13, 1.3.80 & 2.0.0

11. Error Compiling Kernel 1.2.13 on Slackeware 3.00

12. sz/rz got CRC errors under slackware 3.00 w kernel 1.2.13

13. Error on setting up Linux 1.2.13 on a Windows 95 machine