from kernel 1.2.13 ---> 2.0.0

from kernel 1.2.13 ---> 2.0.0

Post by SUPER PHOTON---->* at the Photon Research Lab. in Ma » Tue, 09 Jul 1996 04:00:00



        My computer configuration is with a Cyrix 5X86-120, 16M RAM, a 2GHD,
an ethernet card (3com) ... etc.

        I have installed the slackware 3.0 with kernel 1.2.13 and I wanted
to upgrade the kernel to 2.0.0 but I failed to do this.

        I have followed the following instructions in installing the
kernel 2.0.0.

        mv linux-2.0.tar.gz /usr/src
        cd /usr/src
        mv linux linux.old
        gzip -d linux-2.0.tar.gz
        tar xvf linux-2.0.tar
        cd linux
        make mrproper
        <start x-win> make xconfig <exit x-win>
        make dep
        make clean
        mv /vmlinuz /vmlinuz.old
        vi /etc/lilo.conf  ------> change the line that reads /vmlinuz
                                   /vmlinuz.old
        make zlilo
        reboot

        BUT after all of these and reboot, some errors appear as follow:

                        .
                        .
                        .                                              
        SIOCSIFBRDADDR: No such device
        SIOCSIFNETMASK: No such device
        SIOCADPRT: Network is unreachable
        SIOCADPRT: Network is unreachable
                        .
                        .
                        .
        Error: The module was complied on kernel version 1.2.13
               This kernel is version 2.0.0. They don't watch.
               Check that module is usable with the current kernel.
               Recompile the kernel and try again.

        Would you mind giving me some advice such that I can correct these
errors?

        Thanks a lot!!!!
--
           t      |                         b b b      a    n     n    gggg
          t      / \                        b     b    a    n n   n   g
         t     /     \                      b b b     a a   n  n  n  g   ggg
        t    '   \ /   '                    b     b  a = a  n   n n   g    g
       t   ./ ''./ \.'' \.                  b b b   a     a n     n      ggg
    t t t /               \     a  a                                
    /. \   / .         . \   a        a     d d        o o    l      l    
    t \ \ / / \       / \ \a  /  /  /   a   d    d   o     o  l      l
        \./     \   /    \.a  \  \  \   a   d     d  o     o  l      l
            /\./    \./\   a    / / /   a   d    d   o     o  l      l
             \        /      a  ///   a     d d        o o    l l l  l l l
             / \.   ./ \        a  a                          
       . /\/  /  \./  \  \ /\ .  
         \. /           \  ./
           \ \          / /        
            \.\       /./
     ._______/ \     / \________.
      \_______/      \________/              

 
 
 

from kernel 1.2.13 ---> 2.0.0

Post by SUPER PHOTON---->* at the Photon Research Lab. in Ma » Tue, 09 Jul 1996 04:00:00


        BUT after all of these and reboot, some errors appear as follow:

                        .
                        .
                        .                                              
        SIOCSIFBRDADDR: No such device
        SIOCSIFNETMASK: No such device
        SIOCADPRT: Network is unreachable
        SIOCADPRT: Network is unreachable
                        .
                        .
                        .
        Error: The module was complied on kernel version 1.2.13
               This kernel is version 2.0.0. They don't watch.
               Check that module is usable with the current kernel.
               Recompile the kernel and try again.

        Would you mind giving me some advice such that I can correct these
errors?

        Thanks a lot!!!!
--
           t      |                         b b b      a    n     n    gggg
          t      / \                        b     b    a    n n   n   g
         t     /     \                      b b b     a a   n  n  n  g   ggg
        t    '   \ /   '                    b     b  a = a  n   n n   g    g
       t   ./ ''./ \.'' \.                  b b b   a     a n     n      ggg
    t t t /               \     a  a                                
    /. \   / .         . \   a        a     d d        o o    l      l    
    t \ \ / / \       / \ \a  /  /  /   a   d    d   o     o  l      l
        \./     \   /    \.a  \  \  \   a   d     d  o     o  l      l
            /\./    \./\   a    / / /   a   d    d   o     o  l      l
             \        /      a  ///   a     d d        o o    l l l  l l l
             / \.   ./ \        a  a                          
       . /\/  /  \./  \  \ /\ .  
         \. /           \  ./
           \ \          / /        
            \.\       /./
     ._______/ \     / \________.
      \_______/      \________/              

 
 
 

from kernel 1.2.13 ---> 2.0.0

Post by mjo.. » Wed, 10 Jul 1996 04:00:00


[ excessive line posts deleted ]

Quote:

>    mv linux-2.0.tar.gz /usr/src
>    cd /usr/src
>    mv linux linux.old
>    gzip -d linux-2.0.tar.gz
>    tar xvf linux-2.0.tar
>    cd linux
>    make mrproper
>    <start x-win> make xconfig <exit x-win>
>    make dep
>    make clean
>    mv /vmlinuz /vmlinuz.old
>    vi /etc/lilo.conf  ------> change the line that reads /vmlinuz
>                               /vmlinuz.old
>    make zlilo
>    reboot
>Cc:

>>        BUT after all of these and reboot, some errors appear as follow:

>                    .
>                    .
>                    .                                              
>    SIOCSIFBRDADDR: No such device
>    SIOCSIFNETMASK: No such device
>    SIOCADPRT: Network is unreachable
>    SIOCADPRT: Network is unreachable
>                    .
>                    .
>                    .
>    Error: The module was complied on kernel version 1.2.13
>           This kernel is version 2.0.0. They don't watch.
>           Check that module is usable with the current kernel.
>           Recompile the kernel and try again.

>    Would you mind giving me some advice such that I can correct these
>errors?

Try these steps:

        mv linux-2.0.tar.gz /usr/src
        cd /usr/src
        mv linux linux.old
        tar xzvf linux-2.0.tar.gz
        cd linux
        make config
                [ configure your network device - error #1 ]
                [ configure module support ]
        make dep
        make clean
        make zlilo
        make modules
        make modules_install

Error #2: looks like ibcs2 problem. You must recompile this seperately as far
          as I know.

-mike

[ bandwidth wasting signature deleted ]
--
    _________________________________________
    |   My other computer runs Linux.        |
    |           - car bumper sticker         |
    |________________________________________|

 
 
 

from kernel 1.2.13 ---> 2.0.0

Post by Glen Segel » Wed, 10 Jul 1996 04:00:00



Quote:>>                        .                                              
>>        SIOCSIFBRDADDR: No such device
>>        SIOCSIFNETMASK: No such device
>>        SIOCADPRT: Network is unreachable
>>        SIOCADPRT: Network is unreachable

in /etc/rc.d you have rc.inet and maybe even rc.inet1 and rc.inet2
In these files it is specified your network configuration. Most likely
after installing all your new stuff that you have yet to do a new
netconfig. You can enter these files manually and hash out all reference
to IP if you are not connected via ethernet. If you are on a modem then
all the work will be done through your dialing scripsts ie ifconfig and
route.

-- Glen Segell

 
 
 

from kernel 1.2.13 ---> 2.0.0

Post by Russell Durk » Thu, 11 Jul 1996 04:00:00


When upgrading to 2.0.0 , you also need to upgrade
Binutils and your C library.  Check out

http://www.singnet.com.sg/~sunsurf/welcome.html

for great step by step instructions.  I was able to upgrade
from 1.2.13 to 2.0.0 in a few hours with little difficulty

Russell

 
 
 

from kernel 1.2.13 ---> 2.0.0

Post by David Woo » Sat, 13 Jul 1996 04:00:00




>When upgrading to 2.0.0 , you also need to upgrade
>Binutils and your C library.  Check out

>http://www.singnet.com.sg/~sunsurf/welcome.html

>for great step by step instructions.  I was able to upgrade
>from 1.2.13 to 2.0.0 in a few hours with little difficulty

>Russell


I found that you needed to upgrade nettools to 1.32alpha. Apparently
this is recommended in 2.0.4 and higher, but I've stuck at 2.0.3 as
people have reported compile problems with patchlevel 4 and 5.

--
David Wood

 
 
 

1. strange problems 1.2.13 --> 2.0.0 --> 1.2.13

Hi,

I have some strange problems with the new kernel source tree...

after the installation of the new sysvinit-2.62 the linux-2.0.0 kernel
complains sh:/bin/bash cannot execute...
with 1.99.7 this works fine
and at least I'm totally unable to recompile the 1.2.13 source tree due
some strange asm errors in main occurring in asm/io.h referenced by
bugs.h  (also within the asm tree). Of course I checked the appropriate
links to for the linux source tree /usr/include/linux
                                                asm

Please help....
 Michael

-------------------------------------------------------------------------------
        Michael Rietz                   |       Office: 13

        Werner Heisenberg Institut      |       phone:+49-(0)89-32354-242,
        Foehringer Ring 6               |                             415,411
        D-80805 Muenchen                |       fax:    +49 (0)89 3226704
                                        |
                            is there anybody OUT there...
-------------------------------------------------------------------------------

2. "exceptional circumstances" on sockets

3. Problem with NCSA-Telnet and kernel > 1.2.13

4. HELP!!

5. Kernel 1.2.13: Files > 2MB via POP3 Brings Mail-Hub to its Knees

6. New or Revised TAs on websco, 960621

7. Problems with pppd and kernel > 1.2.13

8. Diamond Speedstar SX24

9. Help: Upgrade kernel 1.2.13->2.0.21

10. Kernel upgrade [1.2.13 ==> 1.3.45] breaks PPP

11. 1.2.13 -> 2.x.x Kernel and 2940 boot problems

12. kernel 1.2.13 -> 2.0.31

13. NCSA httpd on kernel<>1.2.13?