ide-scsi emulation and cdrom devices

ide-scsi emulation and cdrom devices

Post by Jim Comstoc » Sun, 31 Dec 1899 09:00:00



 I'm running RedHat 5.2.  My disk configuration is as follows:

ide0:    Master    Western Digital 5gb hard disk
            Slave        Western Digital 2 gb hard drive
ide1:    Master    Memorex 40x cdrom
            Slave        HP cd burner
AdvanSys SCSI:    0        Tandberg 2gb tape drive
                                1        IBM 2gb disk drive (my root
disk).

    I installed cdrecord and xcdroast.  In order to access the cd
burner, I had to enable ide-scsi emulation, and turn off the eide
support for ide cdroms (involved a kernel rebuild).  Everything works
fine now, except I can't figure out what device the cdroms are at to
mount/read cd's.  The Memorex
used to be hdc, the HP hdd.   I aliased the AdvanSys to be the first
scsi adapter and the ide as adapter1.   I can't figure out which device
to mount the cdrom on.  If I try hdc, I get error messages about illegal

scsi instructions ( I expected this to fail).  The device for my root
disk is sda2 (the first partition is for swap).  I expected the cdrom to

be sdb1, but no luck.  My hard drives are still hdax and hdbx.  What
device should my cdrom's be?

jim c

 
 
 

1. ide-scsi emulation and cdrom mount

 I'm running RedHat 5.2.  My disk configuration is as follows:

ide0:    Master    Western Digital 5gb hard disk
            Slave        Western Digital 2 gb hard drive
ide1:    Master    Memorex 40x cdrom
            Slave        HP cd burner
AdvanSys SCSI:    0        Tandberg 2gb tape drive
                                1        IBM 2gb disk drive (my root
disk).

    I installed cdrecord and xcdroast.  In order to access the cd
burner, I had to enable ide-scsi emulation, and turn off the eide
support for ide cdroms (involved a kernel rebuild).  Everything works
fine now, except I can't figure out what device the cdroms are at to
mount/read cd's.  The Memorex
used to be hdc, the HP hdd.   I aliased the AdvanSys to be the first
scsi adapter and the ide as adapter1.   I can't figure out which device
to mount the cdrom on.  If I try hdc, I get error messages about illegal
scsi instructions ( I expected this to fail).  The device for my root
disk is sda2 (the first partition is for swap).  I expected the cdrom to
be sdb1, but no luck.  My hard drives are still hdax and hdbx.  What
device should my cdrom's be?

2. Modem-SLIP-Problem

3. PROBLEM: bad device file for cdrom while using devfs and ide-scsi

4. Resolving conflicting Index options?

5. SCSI card and ide-scsi emulation: should they work together?

6. bash setenv error

7. SCSI controler and ide-scsi emulation

8. Linux vs. Win95

9. timeout on TUR to IDE CDROM using SCSI emulation

10. Is there DISadvantage to scsi emulation for ide cdrom reader?

11. Sound and SCSI emulation of IDE CDROM

12. multiple cdrom devices using scsi emulation

13. using ide-scsi & scsi devices