RPM: cannot open //var/lib/rpm/packages.rpm

RPM: cannot open //var/lib/rpm/packages.rpm

Post by Giovanni Ferro Luzz » Sun, 31 Dec 1899 09:00:00



Hi all,
the Subject line says it all:
when I try to install a program via RPM I get this message:
"RPM: cannot open //var/lib/rpm/packages.rpm"
As I'm a newbie, I would very much appreciate the significance of this error
message. Is my RPM program badly installed or cofigured?
Thanks a lot in advance!
Giovanni
 
 
 

RPM: cannot open //var/lib/rpm/packages.rpm

Post by Vilmos Sot » Sun, 31 Dec 1899 09:00:00


Giovanni Ferro Luzzi <ferro_at_uni2a_dot_unige_dot_ch> writes:

Quote:> when I try to install a program via RPM I get this message:
> "RPM: cannot open //var/lib/rpm/packages.rpm"

Are you logged in as root? You can install packages only as root.

Vilmos

 
 
 

RPM: cannot open //var/lib/rpm/packages.rpm

Post by Tim Watkin » Sun, 31 Dec 1899 09:00:00


You need to be logged in as root to use RPM.

Tim


> Hi all,
> the Subject line says it all:
> when I try to install a program via RPM I get this message:
> "RPM: cannot open //var/lib/rpm/packages.rpm"
> As I'm a newbie, I would very much appreciate the significance of this error
> message. Is my RPM program badly installed or cofigured?
> Thanks a lot in advance!
> Giovanni

 
 
 

RPM: cannot open //var/lib/rpm/packages.rpm

Post by Vilmos Sot » Sun, 31 Dec 1899 09:00:00



> You need to be logged in as root to use RPM.

Not always. If you upgrade/install/remove packages, then yes. If you
just query the database, then a regular login will be fine.

Vilmos

 
 
 

RPM: cannot open //var/lib/rpm/packages.rpm

Post by Tim Watkin » Sun, 31 Dec 1899 09:00:00


Technically correct, but the poster specifcally said they were trying to
install RPMS.

Tim



> > You need to be logged in as root to use RPM.

> Not always. If you upgrade/install/remove packages, then yes. If you
> just query the database, then a regular login will be fine.

> Vilmos

 
 
 

1. cannot open //var/lib/rpm/packages.rpm

[ security.eng < 1K ]

After exit the Xwindows the following warnings appear:
--
error opening security policy file
/usr/X11R6/lib/X11/xserver/Security_Policy
sh: /usr/X11R6/lib/X11/xkb/xkbcomp: No such file or directory
Couldn't load xkb keymap, falling back to pre-xkb keymap
--

Does anyone please help me?
(RedHat4.0, kenrnel 2.0.28, PCPentium)


Jan Krupa

2. HW RAID options for E450

3. Should I learn Modula-3? How?

4. Problem with Gnome RPM - Failed to open /var/lib/rpm/packages.rpm

5. ftp? ???? ????? ?? ??

6. RPM for Uwin - cannot open file //var/lib/rpm/nameindex.rpm

7. Tape drive compatibility

8. failed to open //var/lib/rpm/packages.rpm

9. RPM Crashes with "//var/lib/rpm/packages.rpm not found"

10. RedHat 3.0.3 Installation - FAILED TO OPEN "/mnt/var/lib/rpm/packages.rpm"

11. RPM corrupted, rpm --rebuilddb fails and there is data in the /var/lib/rpm directory

12. /var/lib/rpm/packages.rpm