RedHat 5.2 Install Hangs Randomly

RedHat 5.2 Install Hangs Randomly

Post by Tim Evan » Sat, 10 Apr 1999 04:00:00



I'm trying to install RedHat 5.2 on a GW2K 266MHZ P-II, 128MB RAM, one
IDE, one SCSI disk,
Adaptec 2940 controller and SCSI CD-ROM.

Specifically, I want to install on the 9GB SCSI disk (Win 95 is already
on the IDE disk), and
I've installed System Commander.

RedHat install boots from the CD-ROM, finds all the devices, and lets me
partition the
disk and select packages to install.  It then starts installing
packages.  So far, so good.

However--and I have tried this half a dozen times--the system locks up
at a random
point in the install and never finishes.  Sometimes it's only after a
couple of minutes,
other times, its after 15 minutes.  The lockup is never at the same
place, and I've
tried two different RedHat CD's.  (When I say "never finishes" I mean
that I have left it
sit as long as overnight.)

Since the load never finishes, I don't have a bootable system
afterwards, and no
access to what might have been written to the install logfile.  

Presumably, this is a hardware problem, but I have no way of pinpointing
it.

Is there a way to boot to single-user from the CD-ROM and get a shell to
mount the
incomplete filesystems, so I can look for the install log?

Suggestions?  Thanks.
--
Tim Evans                     |    E.I. du Pont de Nemours & Co.

(302) 695-9353/8638 (FAX)     |    P.O. Box 80357

 
 
 

RedHat 5.2 Install Hangs Randomly

Post by patrick won » Sun, 11 Apr 1999 04:00:00



> I'm trying to install RedHat 5.2 on a GW2K 266MHZ P-II, 128MB RAM, one
> IDE, one SCSI disk,
> Adaptec 2940 controller and SCSI CD-ROM.

> Specifically, I want to install on the 9GB SCSI disk (Win 95 is already
> on the IDE disk), and
> I've installed System Commander.

> RedHat install boots from the CD-ROM, finds all the devices, and lets me
> partition the
> disk and select packages to install.  It then starts installing
> packages.  So far, so good.

> However--and I have tried this half a dozen times--the system locks up
> at a random
> point in the install and never finishes.  Sometimes it's only after a
> couple of minutes,
> other times, its after 15 minutes.  The lockup is never at the same
> place, and I've
> tried two different RedHat CD's.  (When I say "never finishes" I mean
> that I have left it
> sit as long as overnight.)

> Since the load never finishes, I don't have a bootable system
> afterwards, and no
> access to what might have been written to the install logfile.

> Presumably, this is a hardware problem, but I have no way of pinpointing
> it.

> Is there a way to boot to single-user from the CD-ROM and get a shell to
> mount the
> incomplete filesystems, so I can look for the install log?

> Suggestions?  Thanks.
> --
> Tim Evans                     |    E.I. du Pont de Nemours & Co.

> (302) 695-9353/8638 (FAX)     |    P.O. Box 80357


Actually, during the installation, you can press alt+F2 to switch to the
message console and see what's happening behind the scene.  Also, I suspect
that it's a scsi problem.  With Redhat 5.2 the support for Adaptec 2940 is
not very satisfactory.  You should go to their support site and download a
boot image file for this particular scsi card and create a boot floppy.
Then use this floppy to boot and start installation.  Make sure that you
use linear option for the card and install lilo on the boot sector of the
root partition instead of the MBR.  If your motherboard supports booting
from scsi devices, make sure you enable it and use lilo to boot both linux
and win95.  Otherwise you might have to create a small partition on the ide
drive for the root partition in order to be able to boot at all.
Patrick

 
 
 

1. RedHat 5.2 install hangs on low memory (8MB) PC

We tried to install RedHat 5.2 on a i486 with 8MB ram. The installation
hangs after SCSI recognition. The floppy never stops working. We can
hear the head move and move and move ...

On a Pentium Pro PC with more ram everthing works fine. But if we reduce
the amount of ram with a kernel option "mem=8M" the same behaviour
occurs.

Any hints?

Oliver

--
     \\|//      Tel. +49-89-289-164-32
     (o o)      FAX  +49-89-289-164-10
+-oOO-(_)-OOo-+ PGP key ID: 1024/84E9FBB1

+-------------+ http://www.itm.tum.de/~kaiser

2. MAE you make the call

3. RedHat 5.2 Install Hangs on "idle task may not sleep"

4. cgiparse OR uncgi - which is 'best'?

5. Redhat 5.2 DNS install hangs nslookup.

6. Partition Resize

7. Installing RedHat 6.0 over Redhat 5.2

8. new install of AIX 4.3.3, ESC key not working

9. Installing non-builtin ethernet driver for use with ftp install of redhat 5.2

10. Linux (both redhat & slackware) hangs randomly on new setup...

11. Redhat 5.2 hangs on shutdown.

12. Netscape 4.8/Redhat 5.2 just hangs very often

13. Help: FTP hang Solaris 2.6->Redhat 5.2