Missing /dev/console under 2.0.27

Missing /dev/console under 2.0.27

Post by Chris Shepar » Fri, 07 Feb 1997 04:00:00



Hi all,
        When I went to 2.0.27, I installed it on a different drive,
keeping my previous version (1.2.13) on a downed drive.  All was
kewl except that X wouldn't run because 2.0.27 didn't set up a
/dev/console file.  I had to bring back the old drive, mount it
under /old and soft link to it ( ln -s /old/dev/console /dev/console )
to get X going.
        Problem is that now I want to waste the old drive and run
purely from the new installation, but I can't without a /dev/console,
and cp /old/dev/console /dev/console ain't cuttin' it.  (Yes, I
unlinked it first.  :-) )

        Any pointers to where I can read up on these special
devices and finger out what went wrong (and, of course, how to fix it)?

        Many TIA.

--


aka Maverick Software
aka Chris Shepard
http://maverick.mastermind.net/

 
 
 

Missing /dev/console under 2.0.27

Post by Yon Han Chon » Fri, 07 Feb 1997 04:00:00



> Hi all,
>         When I went to 2.0.27, I installed it on a different drive,
> keeping my previous version (1.2.13) on a downed drive.  All was
> kewl except that X wouldn't run because 2.0.27 didn't set up a
> /dev/console file.  I had to bring back the old drive, mount it
> under /old and soft link to it ( ln -s /old/dev/console /dev/console )
> to get X going.
>         Problem is that now I want to waste the old drive and run
> purely from the new installation, but I can't without a /dev/console,
> and cp /old/dev/console /dev/console ain't cuttin' it.  (Yes, I
> unlinked it first.  :-) )

>         Any pointers to where I can read up on these special
> devices and finger out what went wrong (and, of course, how to fix it)?

Try to make console by doing:

   cd /dev
   ./MAKEDEV console

This might help.

--
----------------------------------------------------------------------
Yon Han Chong                     |
Flow Control and Prediction Group | Tel: + 44 1234 750 111 ext.5356
Cranfield College of Aeronautics  | Fax: + 44 1234 752 149

United Kingdom                    |
----------------------------------------------------------------------

 
 
 

1. 2.0.27 compiles, 2.0.29 doesn't (missing header files?)

I have a weird problem.

I've installed the 2.0.27 kernel from linux-2.0.27.tar.tz, and got a
clean compile (and a stable kernel that works fine). Then I applied the
patches to 2.0.28 and 2.0.29, and now the kernel won't compile. I won't
even get as far as 'make dep'! When I run 'make.dep', make exits with
the complaint that it can't find asm.h...

This is funny - I've got a 'clean' configuration (no paths or
directories modified, everything should be there where it belongs) and
these kernel patches usually work without problems. I don't get any
errors from 'patch' either.

Suggestions anyone? Please reply (or cc) to my email address. Thanks!
--

Regards,
  Frank van Wensveen

=============================================================
Lucent Technologies [CONTRACTOR], Hilversum, The Netherlands
P.O box 1168    1200 BD  Hilversum    The Netherlands

Phone (office): +31-35-6872207  (mobile) +31-652-762303
=============================================================
            *** All standard disclaimers apply ***
=============================================================

2. Problem to use a PC as serial console ...

3. libg++.so.27 and libstc++.so.27?

4. Dell XP Latitude Port Replicator question

5. 2.5.40 s390 (27/27): control characters.

6. X-server/client on remote doesn't work

7. >/dev/msglog 2<>/dev/msglog </dev/console

8. Printcap for BJC-4100

9. Missing /dev/console!

10. Missing /dev/console ?

11. X Windows: /dev/console missing

12. X-Windows won't start: /dev/console missing