LILO says "Invalid partition table"

LILO says "Invalid partition table"

Post by leoma.. » Sun, 31 Dec 1899 09:00:00



LILO keeps giving me "Invalid partition table" errors when I try to add
a boot entry for Windows into lilo.conf.  Windows is on a drive
connected to a Promise Ultra66 IDE controller (hde).  I have Mandrake
7.0.2 installed on a 5GB drive on the primary IDE master (hda), with the
kernel and LILO packages updated from the 7.1 release.  This newer
kernel recognizes the Ultra66 during boot just fine and the newer LILO
has no 1024-cylinder limitation so I *thought* this would work.

There's nothing wrong with the partition table on the drive connected to
the Ultra66; every utility I have says it's fine.  It was fdisk'd and
formatted using Win98 commands, so there isn't that known problem caused
by using Partition Magic.

Any ideas what's going wrong?

Thanks,

- Leo

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

1. LILO complains "Invalid partition table"

I'm trying to set up a new Gateway Solo 3350 (20 GB disk) to dual boot
WindowsME and Debian Linux.  I used FIPS (latest version, downloaded
from the home site) to split the original FAT32 partition, and the
fdisk on the Debian 2.1 installation disk to delete the second
partition and install two new ones.  I got Linux installed on
/dev/hda3, and can boot it with a floppy.  Putting LILO on the MBR
failed, so I restored it with the DOS fdisk ("fdisk /mbr"). I'm now
trying to install the LILO loader on /dev/hda3.  However, LILO
complains about the partition table:

  Script started on Wed Jul 11 16:30:41 2001
  talon:~# fdisk -lu /dev/hda

  Disk /dev/hda: 255 heads, 63 sectors, 2432 cylinders
  Units = sectors of 1 * 512 bytes

     Device Boot    Start       End    Blocks   Id  System
  /dev/hda1   *        63  32354909  16177423+   c  Win95 FAT32 (LBA)
  /dev/hda2      32354910  32852924    249007+  82  Linux swap
  /dev/hda3      32852925  39070079   3108577+  83  Linux
  talon:~# lilo -v
  LILO version 21.5-1 beta, Copyright (C) 1992-1998 Werner Almesberger
  'lba32' extensions Copyright (C) 1999,2000 John Coffman

  Reading boot sector from /dev/hda3
  Device 0x0300: Invalid partition table, 3rd entry
    3D address:     63/254/1021 (16418429)
    Linear address: 1/0/2045 (32852925)
  talon:~# exit

  Script done on Wed Jul 11 16:30:57 2001

I remember FIPS mentioning an incorrect entry, but it assured me that
was no problem.  Not so, apparently.  I would appreciate any pointers
on diagnosing and fixing this.

My lilo.conf is attached, but I don't think lilo got far enough to
read it.

                - Jim Van Zandt

lba32
boot=/dev/hda3
root=/dev/hda3
compact
install=/boot/boot.b
map=/boot/map
delay=20
vga=normal
default=Linux
image=/boot/bzImage-2.4.5
        label=Linux
        read-only
image=/vmlinuz
        label=Linux-2.2.17
        read-only
image=/vmlinuz.old
        label=LinuxOLD
        read-only
        optional
other=/dev/hda1
        label=WindowsME
        alias=3

2. PATCH: ide-probe updates

3. CONFUSCIOUS SAY: lilo says invalid partition table

4. X over the internet

5. I say "Hello" Linux says "Goodbye" ... aaarghhh

6. MSTPPP Connection Nearly Always UP

7. Help Me: Dos "Invalid partition table" errot

8. nroff/troff

9. new filesystem problems: "fdisk: can't write fdisk partition table: Invalid argument"

10. What to do about "invalid partition table"?

11. "Invalid Partition Table" after dd command

12. "Invalid partition table" error message

13. RedHat 7.2: "Invalid partition table"