upgrading ld.so

upgrading ld.so

Post by Chad Wilco » Fri, 15 Aug 1997 04:00:00



I have Redhat linux 4.0 installed on my i486.  I would like to
install JDK 1.1.1.  In order to do that I should have the following
upgraded.

-------
The JDK 1.1.1 for Linux was created under the following environment.

Libary Revisions

         libc version 5.4.13
         ld.so version 1.8.5
         XFree86 version 3.1.2
-------

I checked my versions:

# rpm -q libc
libc-5.3.12-17
# rpm -q ld.so
ld.so-1.7.14-5
# rpm -q XFree86
XFree86-3.1.2-11

I am behind in libc and ld.so.  I would like to upgrade using rpm
ld.so and libc.  I started with ld.so first and this is what
happened.

-----
# rpm -U ld.so-1.8.1-1.i386.rpm
failed dependencies:
        libdl.so.1 is needed by XFree86-3.1.2-11
        libdl.so.1 is needed by blt-1.9-3
        libdl.so.1 is needed by expect-5.19-5.20beta-3
        libdl.so.1 is needed by ical-2.0p2-7
        libdl.so.1 is needed by mc-3.2.10-1
        libdl.so.1 is needed by passwd-0.50-2
        libdl.so.1 is needed by perl-5.003-5
        libdl.so.1 is needed by python-1.3-11
        libdl.so.1 is needed by redbaron-3.0-1
        libdl.so.1 is needed by sh-utils-1.12-10
        libdl.so.1 is needed by tcl-7.5-3
        libdl.so.1 is needed by tclx-7.5.2-3
        libdl.so.1 is needed by tix-4.0.5-3
        libdl.so.1 is needed by tk-4.1-3
        libdl.so.1 is needed by xlispstat-3.44-5
        libdl.so.1 is needed by xlockmore-3.9-4
        libdl.so.1 is needed by NetKit-B-0.08-8
        libdl.so.1 is needed by util-linux-2.5-28
        libdl.so.1 is needed by linux.jdk.shared-1.0.2-2
        libdl.so.1 is needed by samba-1.9.16p9-8
        libdl.so.1 is needed by wu-ftpd-2.4.2b12-4
        libdl.so.1 is needed by imap-4.1.BETA-3
-----
Can someone point me to some documentation on how to do this
correctly?  Maybe even throw a few hints this way.  Is it
even necessary?

Thanks for any help.

Chad Wilcox