Sector Not Found Error during Partition Check

Sector Not Found Error during Partition Check

Post by Kris » Wed, 01 Jan 1997 04:00:00



I'm getting a "sector not found" error when booting linux v2.  The error
occurs when linux is trying to read the partition sector from my hard
drive: /dev/hda.  Other devices like my CDROM drive are detected just fine.

The system is an older 486 with a 130mb Seagate drive ST1144a.  I would
like to use it as a firewall and print server.  The drive geometry is 1001
cyl, 15 heads, 17 sectors.   (I even passed this info to the kernel at the
boot prompt)

When I boot DOS I have no problem accessing the drive with FDISK.  I can
create/display partitions with no errors.

Using the linux version of FDISK, I get the same "sector not found" error.

Any suggestions appreciated.

 
 
 

1. bad partition table error during Partition Check

I'm finally getting around to updating my Linux system.  I currently have
1.1.59 (I know it's old:).  It was the Slackware distribution.

I'm trying to install 1.2.8 from InfoMagic (August 1995 disks).  
It is also the Slackware distribution.  I've tried the bare and scsi
boot images and they both give me the same error during boot
during the partition check:

Partition Check:
hda: bad partition table
hdb: bad partition table

When I get to the login and login as root and run fdisk, it spews out lots
of stuff, but nothing related to my actual partitions.

I can still boot my 1.1.59 disks fine, so I know it's not really a
problem with my partition tables.  Also, everything checks out fine under DOS.

My system has a Promise DC-4030VL caching IDE controller.  2 512M IDE drives.
Adaptec AHA 2842 VL SCSI controler with a SCSI CD-ROM.

Any clues to what this problem really is and how to fix it would be
appreciated.

Thanks in advance,
Wayne Mock

BTW, the same thing happened with the RedHat distribution with 1.2.11.

2. Best method to compile kernel 2.1.72 on 2.0.32 system?

3. Looking for perfmeter, calculator and calendar tool

4. Errors on booting during partition check

5. LILO and Coherent.

6. LBA Sector Not Found Error

7. Building a LINUX router machine...

8. Bad sectors found during formatting

9. KDEstudio -> checking for Qt... configure: error: Qt (>= 19991109) (libraries) not found.

10. Partition check order in fs/partition/check.c?

11. RH 5.2 Install Freezes during Partition Checking

12. lilo error: Partition entry not found