mitsumi fx400 freezes everything ...

mitsumi fx400 freezes everything ...

Post by Thomas Sicherit » Fri, 17 May 1996 04:00:00



hej

Now I tried the most with my CD. I have a mitsumi fx400 (atapi) cd.
In the beginning I was able to read some directories
under from the mounted cd drive, before everything just
freezed. Now I cant even make a ls or unmount the drive without
everything* up. It isnt possible to play audio cd's either.

I recompiled the kernel (1.2.13) with ide support, the cd is configured
as master, I start in lilo with  append = "hdc=170,14" ...
Still it freezes ... the same thing happend with the vertos atapi
cd I had before :-(

I have a Scandic DX4, 1G/16M, Stealth S3 and one modem.
The cd works fine under dos/win95 but the modem doesnt - because of
some conflict with th S3-card ... can this influence the cd under
linux ?

Any help somewhere ???
-thomas

Sicheritz Ponten Thomas E.              UPPSALA UNIVERSITY
Vangsbyvaegen 128   S-740 20 Vaenge     Biomedical Center
Home: +46 18  364358                    Department of Molecular Biology
BMC:  +46 18  174379                    BOX 590 S-751 24 UPPSALA Sweden
Fax   +46 18  557723                    http://www.veryComputer.com/~thomas

        Chaos always defeats order,
                because it is better organized.
                                               (Terry Pratchett)

 
 
 

mitsumi fx400 freezes everything ...

Post by Alex Butch » Sat, 18 May 1996 04:00:00



>hej

Hiya

Quote:>Now I tried the most with my CD. I have a mitsumi fx400 (atapi) cd.
>In the beginning I was able to read some directories
>under from the mounted cd drive, before everything just
>freezed. Now I cant even make a ls or unmount the drive without
>everything* up. It isnt possible to play audio cd's either.

Been there, seen that. My guess is you have a CMD640-based EIDE controller.
The CMD640 is infamous for the number of flaws in its' design (five at the
last count :). You could try adding the lilo 'append' parameters

        hda=serialize
        hdb=serialize
        ide0=serialize
        ide1=serialize

In that order, one at a time, then combinations. The first one should fix it
though. Based on my experience, CD-Rom access becomes very slow after the
first 100KB or so (i.e. the CD-Rom buffer at a guess). To fix this, I
jumpered and cabled my FX400 as slave on the primary channel and stopped
using the secondary channel altogether. If you don't have 3 (E)IDE drives
that's probably the best solution.

If you do have 3 drives, you could try getting a new kernel (but that'll
mean you also upgrading various system utilities - read
/usr/src/linux/Documentation/Changes before you start using it!) or you
could get a new EIDE controller that _doesn't_ use the CMD640, the RZ1000 or
a SMC controller.

Quote:>I recompiled the kernel (1.2.13) with ide support, the cd is configured
>as master, I start in lilo with  append = "hdc=170,14" ...
>Still it freezes ... the same thing happend with the vertos atapi
>cd I had before :-(

Yup, it would do. It's a controller problem rather than a drive problem.

Quote:>I have a Scandic DX4, 1G/16M, Stealth S3 and one modem.
>The cd works fine under dos/win95 but the modem doesnt - because of
>some conflict with th S3-card ... can this influence the cd under
>linux ?

Two answers for the price of one here! I bet you have the modem configured
as COM4, right? Put it on COM1-3 instead. S3-based cards (and 8514/A-alike
cards in general) use the same port address.

Quote:>Any help somewhere ???
>-thomas

Regards,
Alex.
--
Alex Butcher - Micro Support Technician  Tel +44 (0)117 928 9000 x3038
Computing Service, University of Bristol, Tyndall Ave. Bristol BS8 1UD
http://www.veryComputer.com/~ccajb/Welcome.html  #include <stdisclaim.h>

 
 
 

mitsumi fx400 freezes everything ...

Post by Thomas Halenbe » Mon, 20 May 1996 04:00:00


: hej

: Now I tried the most with my CD. I have a mitsumi fx400 (atapi) cd.

My Mitsumi-ATAPI is running ok since I created new special-device-
files for hdc and hdb. The latest kernels need a different major-
number. See in the dir for the kernel-driver-sources. There is a
appropriate MAKEDEV.ide1-Script.
I also added "hdc=cdrom" into lilo.conf. Hope it solves your
probs.
--
------------------------------------------------------------------------
| Thomas Halenbeck      Frankfurter Str. 4    65479 Raunheim, Germany  |

------------------------------------------------------------------------

 
 
 

mitsumi fx400 freezes everything ...

Post by Peter Stewa » Tue, 21 May 1996 04:00:00



: : hej
:
: : Now I tried the most with my CD. I have a mitsumi fx400 (atapi) cd.
:
: My Mitsumi-ATAPI is running ok since I created new special-device-
: files for hdc and hdb. The latest kernels need a different major-
: number. See in the dir for the kernel-driver-sources. There is a
: appropriate MAKEDEV.ide1-Script.
: I also added "hdc=cdrom" into lilo.conf. Hope it solves your
: probs.
: --

Which model is it? From my personal experience, and from what I've heard
on some of the PC newsgroups, the Mitsumi FX400D tends to be a piece of
garbage. I understand the FX400E is supposed to solve some of the problems,
but don't quote me on that.

Pete

(NOTE: de.comp.os.linux.hardware deleted from newsgroups line as it is not
valid at my server and I could not post this otherwise)
--
-------------------------------------------------------------------------------
Pete Stewart               | "* is the last refuge of the incompetent"

-------------------------------------------------------------------------------

 
 
 

1. Mitsumi FX400 CDROM on IDE interface

I have an IDE controller card (UN-1075, based on W83757F and W83758P
chipsets) connected to a Seagate ST5850A and a Mitsumi FX400 IDE CDROM
and although the CDROM (configured as slave, the Seagate is master) is
recognized at boot up as hdb it cannot be mounted.  The dmesg command
gives the following information after a mount command which gives the
user a "bad superblock or partition error".  Despite appearances there
is no media change taking place.

-------------------dmesg command output -------------------------------
hdb: cdrom_pc_intr: The drive appears confused (ireason = 0x 1)
hdb: media changed
hdb: cdrom_pc_intr: The drive appears confused (ireason = 0x 1)
hdb: code: 0  key: 0  asc: ff  ascq: 0
hdb: code: 0  key: 0  asc: ff  ascq: 0
VFS: Disk change detected on device 3/64
  hdb:hdb: cdrom_read_intr: bad interrupt reason 1
end_request: I/O error, dev 0340, sector 1
 unable to read partition table
hdb: cdrom_read_intr: bad interrupt reason 1
end_request: I/O error, dev 0340, sector 5
EXT2-fs: unable to read superblock
-------------------end dmesg command output --------------------------

My conclusion: It will not work.  I have tried switching master and
slave, using line control.  What is wrong?

                                                TMiller
                                                Brandeis U.
                                                Waltham, MA, USA

2. Iptables script

3. Mitsumi FX400 CD-Rom problem

4. fetchmail

5. Mitsumi FX400 CD ROM

6. UNIX PC and multiple filesystems?

7. Patch for mitsumi fx400?

8. Pthread cancellation in Solaris 2.6

9. KERNEL PANIC: Linux CDROM driver fails badly for Mitsumi FX400 with CMD640 IDEs

10. FX400 Quad Speed (Mitsumi) CDROM probs (Why does this happen....)

11. 4x cdrom: Mitsumi FX400 vs. Plextor scsi ?

12. Mitsumi FX400 cd-rom

13. cdrom mitsumi fx400 4x