HELP!! Linux Hangs during boot

HELP!! Linux Hangs during boot

Post by Jess » Sat, 09 Sep 2000 14:42:57



Hi, I have installed RedHat Linux 6.0 on my pc. It has been working fine
(for about a year now) without sound (I didn't bother setting it up) until
recently, when I decided to try to configure my sound card.  I used the
'sndconfig' program, and during setup I decided it was too much trouble (for
now) to set up, so I cancelled. Everything worked fine until I tried to
reboot Linux again. It tries to load the midi module (which it didn't do
before) and just stops...I can't get into Linux!

I just need to get into linux...can anyone help me? is there a way of
disabling some of what it tries to load? I have a boot disk, but all that
does is boot into linux, and still gets stuck while loading the midi
module...I don't think I have a rescue disk...please, any suggestions will
be greatly appreciated. Please send all your solutions/suggestions to

 
 
 

HELP!! Linux Hangs during boot

Post by Eric » Sat, 09 Sep 2000 18:03:16



> Hi, I have installed RedHat Linux 6.0 on my pc. It has been working fine
> (for about a year now) without sound (I didn't bother setting it up) until
> recently, when I decided to try to configure my sound card.  I used the
> 'sndconfig' program, and during setup I decided it was too much trouble (for
> now) to set up, so I cancelled. Everything worked fine until I tried to
> reboot Linux again. It tries to load the midi module (which it didn't do
> before) and just stops...I can't get into Linux!

> I just need to get into linux...can anyone help me? is there a way of
> disabling some of what it tries to load? I have a boot disk, but all that
> does is boot into linux, and still gets stuck while loading the midi
> module...I don't think I have a rescue disk...please, any suggestions will
> be greatly appreciated. Please send all your solutions/suggestions to


I'm not sure about RH 6.0 , but at least later versions offer you the
interactive mode during boot (hit i IIRC). Then you can choose not to
load the modules.

Eric

 
 
 

1. Hang during boot... please help?

I'm trying to install Linux on a 486DX2/66 with 16MB RAM, IDE hard disk with
more than 1024 cylinders, PCI+VLB+ISA mainboard (I know this is strongly not
recomended, but the shop said they would replace it for a VLB+ISA if it fails
to work with Linux), Soundblaster with on board Adaptec 152x, #9 GXE64 with
4MB VRAM (PCI), NE2000 ethernet card, SCSI CD-ROM drive (Matsushita) and an HP
DAT drive.

I have used the October Infomagic CD-ROM which contains Slackware 2.0.1 with
kernel 1.1.50. The boot disk contains kernel 1.0.9 and I use "hd=1048,16,63
aha152x=0x340,11,7,1" as the kernel command line. The whole thing boots fine,
I partition the drive with fdisk (keeping under cylinder 1024 for the root
partition just to make sure) and install a minimum config with setup. I add
the append="..." and linear statements to the lilo.conf and install it on the
MBR (I also tried a floppy).

When I boot off the hard disk, the kernel is loaded fine, it finds the serial
ports (I have 4), lp_init does it's stuff and it arrives at the "Calibrating
delay loop... ok - 33.22 BogoMips" (it seems to me this should be 66.xx !?! )
and then it hangs!!

I then borrowed the December Infomagic CD-ROM which contains Slackware 2.1.0
with kernel 1.1.54. The boot disk also contains kernel 1.1.54 and guess
what... it hangs after the "Calibrating delay loop... ok - 33.22 BogoMips"! So
this time I can't even try installing anything. At least it seems that it
wasn't something I was doing wrong in the installtion process.

Why doesn't it work with the newer kernels ? Is it the PCI based mainboard
which is causing the problem ?

Please help me... thanks in advance.

 ..Yves

--

Yves PERRENOUD        FIDONET  : 2:301/315.50 (pyves)


    <http://neli00.eicn.etna.ch/utl/pyves/home/home.html>

2. 2.5.73-bk5 -- drivers/built-in.o(.text+0x5e3f6): In function `hidinput_hid_event': : undefined reference to `input_event'

3. SCO Unix hang during boot after kernel rebuild - help!

4. Denial of Access of mailbox in unix

5. Help: console output hang during boot

6. Help with XFree 3.2 configuration

7. Boot hang during install... help...

8. mount-fstab-mtab-ps problems with pl11 (second plea!)

9. Slackware 3.3: need help with hang during boot

10. linux hangs during boot

11. Linux hangs during boot

12. Linux RH 7.2 compiling new stock 2.4.7.10, hangs on USB during boot

13. pfat linux hangs during boot