NIS problem on Alpha Linux

NIS problem on Alpha Linux

Post by Fran L » Sun, 31 Dec 1899 09:00:00



Hello,

We are have a problem implementing NIS on some Compaq Alpha
machines running Linux 2.2.5-22 & RedHat 5.2.  Other background
info:

(One alpha machine is a slave server, the master is on a
non-alpha machine running linux)

$ypserv -v
ypserv - NYS YP Server version 1.3.7 (with tcp wrapper)

$ypbind -v
ypbind version 3.3-glibc3

$rpm -qa | grep glibc
glibc-2.0.7-29

I have been able to implement ypserv (for the slave) & ypbind
on all these machines, and am able to successfully mount
NIS-defined automount maps.  

However, on these alpha machines only, a user is not able to
login with userid/password via remote login or on the console
when defined in the NIS password & shadow map.  These same NIS
userid & shadow password maps work well on the other non-alpha
Linux machines in this same NIS domain;
these non-alpha machines are running Linux 2.2.5-22 and RedHat 6.0,
and the same versions of ypserv & ypbind as on the alpha machines.
glibc-2.1.1-6 is installed on these non-alpha machines, whereas
the alphas are still at glibc-2.0.7-29.

I have tried adding "+::::::" to the end of /etc/passwd, trying
the PAM changes as suggested per Thorsten's NIS HOWTO (section 6.8.3),
but nothing seems to work.  Error messages seen in the logs:

FAILED LOGIN 1 FROM ... FOR ..., Authentication failure

Please, anyone have any advice to get this working?

Please also reply directly to my email address, as I do not
frequent this newsgroup very often.

Fran Lawas-Grodek
(remove "**" to reply)

________________________________________________________________

Frances J. Lawas-Grodek       |     phone: (216) 433-5052
NASA Glenn Research Center    |     fax  : (216) 433-8000

Cleveland, Ohio  44135        |  ** office hours until noon **
________________________________________________________________

 
 
 

1. NIS : auth problem with Linux nis server and SUN sparc nis client

Hello,

I'v found some very old message about this problem in this group, but
there was no solution.

I' ve set up a NIS server on a Linux machine ( ubuntu 5.01)
following this howto
http://tldp.org/HOWTO/NIS-HOWTO/index.html
http://doc.ubuntu-fr.org/serveur/nis

everything seems to be ok
my sun machine is binded to ypserv on linux

inv09748 ( my linux nis server)

cao8:$1$JL6XpfxxxxxqctkdfFSycuu/:5008:5000::/home/cao8:/usr/bin/ksh

but when i try to log with cao8 => " incorrect login"

i can only log with root

loggued with root in can do :
su - cao8
and it works fine

so ... if someone can help, i will be very gracefull

(sorry for my english, i'm french)

2. ".htm" files displayed as text...

3. NIS problem on Alpha Linux

4. How to force a socket to send?

5. Solaris NIS server and Linux NIS client : problems

6. c++/g++ name mangling

7. need NIS to run on DEC Alpha Linux box

8. Question: YDL on a HFS+ formatted drive?

9. Solaris 8 Nis+ server and RH Linux 7.3 Nis+ client ---- Problems and Questions

10. NIS on RedHat Alpha Linux

11. Solaris 8 NIS Client Served from NIS on Linux Problem

12. NIS/YP woes on Linux/Alpha

13. Linux NIS with Solaris NIS+ server, password problems.