gimp-print / RPM recursive dependency list?

gimp-print / RPM recursive dependency list?

Post by The.Central.Scrutinizer.wakaw.. » Fri, 02 Aug 2002 23:54:11



I had smb printing using the z52/gimp-print driver once working, but since I
attempted a move to gnome 2, all I get is garbage when I print.

I can't seen to find what rpm got replaced that's messing things up.  

Is there an rpm command to 1) list all packages that a package is dependent on,
as well as 2) list all packages those packages depend on?

 
 
 

gimp-print / RPM recursive dependency list?

Post by Patrick Echterbruc » Sun, 04 Aug 2002 02:11:53


On 1 Aug 2002 08:54:11 -0600

[..]

Quote:> Is there an rpm command to 1) list all packages that a package is dependent on,
> as well as 2) list all packages those packages depend on?

man rpm
QUERY OPTIONS
       The general form of an rpm query command is

            rpm -q [query-options]
[..]
       -R, --requires
              List packages on which this package depends.

       --provides
              List capabilities this package provides.

       --whatrequires <capability>
              Query  all  packages that requires <capability> for
              proper functioning.

       --whatprovides <virtual>
              Query all packages that provide the <virtual>
              capability.

--

--> This email address uses /dev/null as maildrop ;-)
--> To send email, substitute "blackhole" with "pe"

 
 
 

1. Problems with dependencies for gimp-print

I want to install the latest version (4.2) of the gimp-print plugin.
The README says I need cups and recommends cups-1.1.12.   I don't have cups
on my RH7.1 system, but I found an rpm package for it.  That requires
cups-libs.   So I got cups-lib version 1.1.12 also from rpmfind.net.   But
that requires some files from openssl which are bit further along than
the versions I have  (9.6.1 as opposed to 9.6, I think).  Unfortunately,
a whole bunch of things depend on openssl, so persumably I would have to
install upgraded versions of those,  a task I don't want to undertake.

So can anyone advise me about just exactly what I need or some other way
around this difficulty.    Is cups needed if I just want to use the
plugin with the gimp?   Any other suggestions would be helpful.

--


Dept. of Mathematics, Northwestern Univ., Evanston, IL 60208

2. lpd problem

3. No Printing Works Except Gimp-Print

4. Help! Intel Extherexpress not recognized at boot!

5. Dependencies listed by 'rpm -qR (package)'

6. Help installing Video driver!

7. How to install a list of rpms in dependency order

8. route gateway for private lan

9. Compiling gimp-print on Solaris

10. can't compile gimp-print.-4.0.2

11. Anyone compiled gimp-print on Solaris 9?

12. gimp-print won't configure