Kerneld Compilation Problem - No Modules are load after using the new kernel

Kerneld Compilation Problem - No Modules are load after using the new kernel

Post by XIP » Wed, 28 Nov 2001 22:33:08



Hi,

I used Red Hat 7.1 and want to enable IP Masquerade as I want to set up  a
linux router.
So I compile the RH71.
However, after I compile the kerneld and modules, install the kerneld and
update LILO,
restart, and check with the "lsmod" commands, I find No modules were loaded.
Previously, about 10 modules were loaded.

Can anyone help?

Simon

 
 
 

Kerneld Compilation Problem - No Modules are load after using the new kernel

Post by FACORAT Fabric » Thu, 29 Nov 2001 14:50:46



> Hi,

> I used Red Hat 7.1 and want to enable IP Masquerade as I want to set up  a
> linux router.
> So I compile the RH71.
> However, after I compile the kerneld and modules, install the kerneld and
> update LILO,
> restart, and check with the "lsmod" commands, I find No modules were
> loaded. Previously, about 10 modules were loaded.

make modules && make modules_install ?
did you compil they as module ?

--
Quand on ne travailleras plus le lendemain des jours de repos,
la fatigue serat vaincue. Pierre Dac

 
 
 

1. module loading error after new kernel compilation

I have compiled a 2.2.18 kernel on my system without errors.

The problem is that I have is that when I load the modules for my
network cards (both DE202) I get this error:

/lib/modules/2.2.18/net/depca.o: invalid parameter adapter_name

The system is a 5.2 Redhat install, where I have no problems locating
the network cards.

/Mats Mattsson

2. 2.5.62-mjb1 (scalability / NUMA patchset)

3. Problems getting kerneld to auto-load ppa module

4. Refresh Rate at the console

5. Test

6. Can't load modules after kernel 2.4.18 compilation

7. ma600.c won't compile

8. Compilation of a new kernel with compiled modules

9. Using old kernel modules under a new kernel

10. kerneld/module problems with Slackware 3.6 and kernel 2.0.36

11. how can i see if i am using a module or compiled in kernel?

12. Kernel 1.2.13, kerneld, and Modules problem