Problems: libXpm.so.4(netscapeb4) / flock() emulation

Problems: libXpm.so.4(netscapeb4) / flock() emulation

Post by Jo » Tue, 21 May 1996 04:00:00



Well, maybe someone can help me out.

1:

I just got the new netscapeb4 for elf and upon running it tells me it
can't find:  libXpm.so.4.

I searched hard and long for this library and couldn't find it.  I
upgraded my gcc stuff a while back to support aout+elf and this is the
first problem I've run into concerning libraries.

I also recently upgraded to Xfree 3.1.2 and in all the stuff it comes
with I found no such library filename.  Close, but not quite.  I'm
supposing it should be in my /usr/X11R6/lib directory or something
like that.  It is in my ld.so.conf and I've looked on my entire linux
partition and that library isn't to be found.

Cannot find mention of such a library anywhere in the docs with all
the gcc and xfree stuff, nor anything on sunsite or tsx, etc. that
looks like it contains the library.  Although it's part of redhat and
slackware...but I just want that 1 library and all would be happy.

2:

Secondly, if someone would be so kind, I've been baffled by the
"flock() emulation" message that appears upon certain tasks.  I did
upgrade to libc 5.3.12 and ld.so 1.7.14 and infact I did it again,
following the directions precisely, and I STILL have the message.
Anything else I'm missing perhaps?  Exactly WHY does this message
appear..That would probably help.

Hope you have help my decrepid soul.  TIA!

Life is grand, don't mess it up..
Existence is meaningless, buck up!
----------


Web Page:  http://blackhole.dorms.tamu.edu
Ftp Site:  ftp://blackhole.dorms.tamu.edu

 
 
 

Problems: libXpm.so.4(netscapeb4) / flock() emulation

Post by Steven A. Duchen » Tue, 21 May 1996 04:00:00


: I just got the new netscapeb4 for elf and upon running it tells me it
: can't find:  libXpm.so.4.

libXpm is the X pixmap library and is not part of XFree86. You will have to
download it seperatly and compile it for your system. I just did that this
weekend and it was real easy. I believe the current version is 3.4g which
strangely enough produces a library named libXpm.so.4.7  I got my copy from
a sunsite mirror and it was in the pub/linux/libs/X/ directory.

: 2:

: Secondly, if someone would be so kind, I've been baffled by the
: "flock() emulation" message that appears upon certain tasks.  I did
: upgrade to libc 5.3.12 and ld.so 1.7.14 and infact I did it again,
: following the directions precisely, and I STILL have the message.
: Anything else I'm missing perhaps?  Exactly WHY does this message
: appear..That would probably help.

Did you upgrade your a.out libraries at the same time? I upgraded the
a.out stuff to 4.7.5 then installed the 4.7.6 libc version that has some
fixes in it. I believe if you leave the old a.out libraries on the system
you may still see the broke flock messages since you still have executables
on the system that are linked to them.

 
 
 

1. flock() emulation problem

I get a message which seems to be an error after it loads the daemons
saying that a process number has broken flock() emulation.  I got this
message after I upgraded my Slackware 3.0 kernel (can't recall the version
number) to 2.0.0.  

 --
Jonathan Bakert                                 "Question Reality"
Keeper of the WWW Poetry, Lyric, and Short Story Retreat!
(Publish your work on the net easily, instantly, and freely!)
http://www.cris.com/~maendark/retreat.shtml

2. how do I setup SB in Slackware linux?

3. Linux 2.0: lpd problem with flock emulation

4. filemgr under Solaris 2.3

5. Problem with libXpm.so.4.11

6. Help With Shell Script.... goes in a loop and grep script req.

7. libXpm.so.4 problem

8. targa boards?

9. Newbie startx problem: can't load library 'libXpm.so.4'

10. Installing StarOffice: libXpm.so.4 load problem

11. problem opening libXpm.so.4

12. problem with libXpm.so.4

13. libXpm.so problem