RH6.0 - mouse problem in text mode

RH6.0 - mouse problem in text mode

Post by Neno » Thu, 01 Jul 1999 04:00:00



I am running RH6.0 and have a normal serial logitech mouse (3 buttons)
on /dev/ttyS0 configured by mouseconfig as "Microsoft" type. (I guess it
is an alias for "ms").
In X mode my mouse works perfectly.
In text mode with the gpm daemon running, I see the mouse moving as I
want and the copy & paste feature works too.
The problem is when I run Midnight Commander. The buttons don't work (I
cannot pull down the menus, moving through the directories and so on).
Something much strange happen when using Lynx. The left button doesn't
work and pressing the middle one, lynx seems to enter in a loop moving
everywhere, changing url, saving configurations (???).
Running the mev utility I can see the mouse events are trapped correctly
(each button is identified, press and release events too, movements too
and so on).
Before using RH6.0 I have used for a few days a Debian distribution and
in that case the mouse was working correctly both in text and X modes.

Another thing I don't understand:
Running linuxconf (both in text mode or within KDE and with my mouse
moving on the screen),  and quitting without making any change, it says
the status is not in sync with the current configuration and when I ask
to see what is to be updated it says that '/etc/rc.d/rc3.d/S85gpm start'
is to be executed.

Is out there someone with a suggestion ?

 
 
 

RH6.0 - mouse problem in text mode

Post by mimm » Sat, 03 Jul 1999 04:00:00



Quote:>I am running RH6.0 and have a normal serial logitech mouse (3 buttons)
>In X mode my mouse works perfectly.
>In text mode with the gpm daemon running, I see the mouse moving as I
>want and the copy & paste feature works too.
>The problem is when I run Midnight Commander. The buttons don't work (I
>cannot pull down the menus, moving through the directories and so on).
>Before using RH6.0 I have used for a few days a Debian distribution and
>in that case the mouse was working correctly both in text and X modes.

I have the same problem (but I have Ps/2 mouse).
When I used redhat 5.2 all worked fine, but after upgrading to RH6.0 I lost
the graphical ascii character (do you see them?) and the mouse.
I put manually  the line:
 gpm -t ps/2
in my /etc/rc.d/rc.local
and now the mouse works but with the same your problem...
I am still looking for a solution...
If I try it I mail to you (I hope you will make the same) ;-)
Bye

--------------------------
I   My real address is:  I
--------------------------

--------------------------

 
 
 

1. RH6.0: mouse problem in text mode

I am running RH6.0 and have a normal serial logitech mouse (3 buttons)
on /dev/ttyS0 configured by mouseconfig as "Microsoft" type. (I guess it

is an alias for "ms").
In X mode my mouse works perfectly.
In text mode with the gpm daemon running, I see the mouse moving as I
want and the copy & paste feature works too.
The problem is when I run Midnight Commander. The buttons don't work (I
cannot pull down the menus, moving through the directories and so on).
Something much strange happen when using Lynx. The left button doesn't
work and pressing the middle one, lynx seems to enter in a loop moving
everywhere, changing url, saving configurations (???).
Running the mev utility I can see the mouse events are trapped correctly

(each button is identified, press and release events too, movements too
and so on).
Before using RH6.0 I have used for a few days a Debian distribution and
in that case the mouse was working correctly both in text and X modes.

Another thing I don't understand:
Running linuxconf (both in text mode or within KDE and with my mouse
moving on the screen),  and quitting without making any change, it says
the status is not in sync with the current configuration and when I ask
to see what is to be updated it says that '/etc/rc.d/rc3.d/S85gpm start'

is to be executed.

Is out there someone with a suggestion ?

2. KMix: No mixers available

3. NetBSD on Apollo's

4. Problems with Token Ring Adapters & v2.0.23

5. Mouse problems (text mode & X-Windows)

6. Problem bei vmware - installation, brauche ich einen anderen kernel ?

7. RH6.2: Power Management in Text Mode

8. HELP!: MOUSE IN TEXT-MODE!

9. Can't get mouse pointer in text mode

10. PS/2 Mouse in Text Mode; X won't start

11. how to enable mouse in text-mode ?