Adduser stopped working

Adduser stopped working

Post by Matthew Sel » Tue, 24 Nov 1998 04:00:00



Hi,

I have a problem with adduser, i.e. it has ceased to work. When I run
adduser it starts ok,
creates the directory for the user then terminates. It does not ask any
questions about
the desired shell or password etc.

Can anyone explain why this is? The only explaination that I can give is
that I have
upgraded the kernel many times since I last used adduser, but what
effect this would
have I do not know.

Any advice appreciated,

matthew

--
Matthew Sell
Parallel Applications Centre
2 Venture Road, Chilworth
Southampton, SO16 7NP, UK

tel: +44 1703 760834
fax: +44 1703 760833


http://www.pac.soton.ac.uk/

 
 
 

Adduser stopped working

Post by Hap » Tue, 24 Nov 1998 04:00:00


As far as I remember Matt, it *never* asks about that sort of thing.  There
might be a switch you add to have it ask all of that...

H



> Hi,

> I have a problem with adduser, i.e. it has ceased to work. When I run
> adduser it starts ok,
> creates the directory for the user then terminates. It does not ask any
> questions about
> the desired shell or password etc.

> Can anyone explain why this is? The only explaination that I can give is
> that I have
> upgraded the kernel many times since I last used adduser, but what
> effect this would
> have I do not know.

> Any advice appreciated,

> matthew

> --
> Matthew Sell
> Parallel Applications Centre
> 2 Venture Road, Chilworth
> Southampton, SO16 7NP, UK

> tel: +44 1703 760834
> fax: +44 1703 760833


> http://www.pac.soton.ac.uk/


 
 
 

Adduser stopped working

Post by jack » Tue, 24 Nov 1998 04:00:00


Do a cd / first

    Hi,
    I have a problem with adduser, i.e. it has ceased to work. When I run adduser it starts ok,
    creates the directory for the user then terminates. It does not ask any questions about
    the desired shell or password etc.

    Can anyone explain why this is? The only explaination that I can give is that I have
    upgraded the kernel many times since I last used adduser, but what effect this would
    have I do not know.

    Any advice appreciated,

    matthew

--
Matthew Sell
Parallel Applications Centre
2 Venture Road, Chilworth
Southampton, SO16 7NP, UK

tel: +44 1703 760834
fax: +44 1703 760833


http://www.pac.soton.ac.uk/

 
 
 

1. adduser parameters: setting up a batch adduser script

How do I send the parameters to adduser to set things like their shell,
their, password, and their comment (full name)??  I think I have a newer (or
older) version of adduser because it doesn't ask for the parameters like the
old one did.  If I don't give it a username (on the command line) it gives an
error asking for one, and when I do, it just makes the user with defaults (no
password, no comment, and /bin/ash as the shell) it doesn't even ask.  I am
trying to make a batch adduser script and I can't figure out how to send the
parameters that I wan't to adduser.  Is there supposed to be a man page about
it?  I can't find the man page.  I have RedHat 4.0 and I installed
EVERYTHING.  I also can't type adduser --help.  It says something about the
user already existing (even though there is no user named --h in my passwd
file).  Where can I find a man page for adduser?

--

Riley McArdle

http://www.toptown.com/hp/griffon/

2. "Unresolved symbol" when lauching a driver

3. Lucent Venus modem worked for about 1/2 hour then stopped working

4. Squid Proxy Setting

5. adduser not working

6. Netscape servers, digital certificates & access control

7. PPP connection:Windows works, Linux stopped working

8. Linux as a DNS server with MS Proxy 2?

9. how to get useradd (adduser) -p to work

10. LinuxPPC 2000: adduser Works but Authentication Fails

11. working adduser command for 'linux router project' 2.9.4 distro

12. SSH Stops Working on Interface 1, Still Works on Interface 2

13. adduser in SLS 0.98 (I read the FAQ and it still doesn't work)