xwindow image shifting under #9GXEpro

xwindow image shifting under #9GXEpro

Post by Jian Sh » Thu, 20 Jul 1995 04:00:00


_
Dear friends,
_
I got some response for my problem, it seems I did'nt make my problem
clear enough and there is confusion there. So I rediscribe my problem
as following. Helps are greatly appreciated.
_
I just installed Linux slackware this week, and I have the following
annoying problem with the Xwindow image:
_
The system works fine, including virtual desktop, I can use ctrl-alt-
+/- switch to different resolutions, surely the problem exists in every
resolution. And don't misunderstand that's the feature of virtual desk-
top, I know what it is and that works just fine. My real problem is:
        The Xwindow image keeps shaking left and right in a range about 1/8
inch when I move the mouse. That's not the case of the virtual desktop that
the image shifts when the mouse cursor touches the edge of the image and keep
moving further. My shifting problem can occur when the cursor in anywhere on
the screen. But the image stop shaking immediately when I stop moving the
mouse, and the overall image quality(concern color and resolution) is
excellent.  I have tried a lot of timing values and bpp combinations but
can't get it right. Is there anyone have the same situation and can give
help? A XF86Config file will be appreciated.
_
An Email is prefered since I don't check news very often.
_
Here is my hardware spec:
CPU: Pentium75
Monitor: Dell 15 inch color multisync monitor, Model D1526T-HS
_        Max dot clock 135Mhz
_        Horizontal Sync: 31.5-64
_        Vertical Sync:   50-120
Video Card: #9 GXE64 pro with PCI bus and 2Mb VRam
_
Thanks again!
_
Jian Shen


 
 
 

xwindow image shifting under #9GXEpro

Post by Harald Koen » Thu, 20 Jul 1995 04:00:00



Quote:>         The Xwindow image keeps shaking left and right in a range about 1/8
> inch when I move the mouse. That's not the case of the virtual desktop that
> the image shifts when the mouse cursor touches the edge of the image and keep
> moving further. My shifting problem can occur when the cursor in anywhere on
> the screen. But the image stop shaking immediately when I stop moving the
> mouse, and the overall image quality(concern color and resolution) is
> excellent.  I have tried a lot of timing values and bpp combinations but
> can't get it right. Is there anyone have the same situation and can give
> help? A XF86Config file will be appreciated.

wait for XFree86 3.1.2, to be released end of July.
there will be some new config options for the screen section
(EarlySC, InvertVCLK, BlankDelay1 and BlankDelay2) to fix
these problem individually for every card and vide mode.
and there will be a small interactive program "xvidtune"
to test and optimize these parameters while running X...

Harald
--
All SCSI disks will from now on                     ___       _____
be required to send an email notice                0--,|    /OOOOOOO\
24 hours prior to complete hardware failure!      <_/  /  /OOOOOOOOOOO\
                                                    \  \/OOOOOOOOOOOOOOO\
                                                      \ OOOOOOOOOOOOOOOOO|//
Harald Koenig,                                         \/\/\/\/\/\/\/\/\/
Inst.f.Theoret.Astrophysik                              //  /     \\  \


 
 
 

1. problem solved: X window image shifting under #9GXEpro with a PS/2 mouse

The solution is adding a line  
        Option "sw_cursor"
in Section "Device".

        I think quite a bit people like to know this because I keep receiving
messages from them loking for solutions.
        Let me describe the problem again, just people may wonder:

Hardware: #9GXE pro PCI with 2Mb Vram
          Dell 15inch MultiSync Monitor, Model D1526-HS
          PS/2 auxi. mouse
Problem:  the X window image keeps shifting( some people called quivering )
          in a range about 1/8 inch while I move the mouse around.
          Don't confused this with the Virtual desktop feature!! The shifting
          occured while the mouse is in anywhere on the screen!

Hope this will help those people with the same kind machine I have ( a Dell
Petium P75).

Jian Shen

2. Symbios 8600SP

3. xwindow image shifting

4. X problem with tv

5. Image shifts left when switching from X-Windows to terminal

6. swapon: vnd0 device not configured

7. Can I shift screen image by editing mode timings?

8. NIS+ password and lockd problems

9. horizontal shifted double image on Laptop with color lcd

10. x86; new monitor, image shifted to right

11. XF86_S3 image shift

12. #9 GXE64 Pro PCI image shifting problems, Help!

13. #9 GXE64 Pro PCI image shifting problems!