SMC EtherPower and Tulip driver

SMC EtherPower and Tulip driver

Post by Greg Sieka » Sun, 10 Mar 1996 04:00:00






> >> Hi,

> >> it seems Donald Becker's Tulip driver for DEC 21*40-based ethercards does
> >> not work with newer types of SMC EtherPower cards.

> >Right.

> >> I have a EtherPower 8432BT card with 21041 chip and tried version 0.10 of
> >> the driver from Donald's WWW page. It needs some patches, btw., to compile
> >> with kernel 1.3.70.
> >> The card is found at boot time. The 21041 chip, IRQ and IO base are reported
> >> correctly. However, the ethernet adress is wrong. ping gives me 'transmit
> >> timeouts' and arp does not work.

> >> Is is definitely no hardware or PCI problem, since the card works fine with
> >> the supplied Windows drivers.

> >Use DE4X5 driver.

> Using this driver with the SMC cards tends to have limited success (in
> my experience).  Of the two machines I tried it on, one crashed once or
> twice a day when network traffic was high, the other crashed every 5 to
> 10 minutes.  Look at:

Using the de4x5 driver can cause the system to lock up under 1.2.13.  The
driver was not written to support the cards from SMC.

Does anyone have any success or problems using the de4x5 drivers under the
newer 1.3.XX kernels?

Quote:> http://studentweb.tulane.edu/~siekas/linux/smc8432.html
> for more functional drivers for the SMC cards.  Using Manabe Takashi's driver
> (links to it are on the above listed page), these two machines have not
> crashed for three or so weeks.

thanks, that's my page I created since SMC decided to switch chips on me
when I returned my first card went bad that had the older 21040.  I've
been using Manabe's patches on 1.2.13 for over a month without any
problems.  I recently went up to 1.3.72 and used the 1.3.71 patch with no
problems.  Things seems to be working great with the patches.  Thanks
again Manabe.  My page gets hit about 10 times a day.  Can everyone that's

note saying the following and I'll post the results on my page.

type of card: SMC
chip on card: 21041
kernel version: 1.3.72
driver: tulip.c w/ Manabe's patches

thanks,
Greg

 
 
 

SMC EtherPower and Tulip driver

Post by Dwayne Jacques Fonten » Tue, 12 Mar 1996 04:00:00



>thanks, that's my page I created since SMC decided to switch chips on me
>when I returned my first card went bad that had the older 21040.  I've
>been using Manabe's patches on 1.2.13 for over a month without any
>problems.  I recently went up to 1.3.72 and used the 1.3.71 patch with no
>problems.  Things seems to be working great with the patches.  Thanks
>again Manabe.  My page gets hit about 10 times a day.  Can everyone that's

>note saying the following and I'll post the results on my page.
>type of card: SMC
>chip on card: 21041
>kernel version: 1.3.72
>driver: tulip.c w/ Manabe's patches
>thanks,
>Greg

hello,

AMD486DX120 PCI SiS 496/497 chipset.

type of card: SMC
chip on card: 21041
kernel version: 1.2.13
driver: tulip.c w/ Manabe's patches
card mode: 10baseT
------------------------------------------------
result: success! very fast! 950KB/sec ftp on large files!
------------------------------------------------

type of card: SMC
chip on card: 21041
kernel version: 1.3.67
driver: tulip.c w/ Manabe's patches
card mode: 10baseT
------------------------------------------------
result: pings work, machine HANGS on first significant transfer!
        even a telnet will hang the machine.
------------------------------------------------

type of card: SMC
chip on card: 21041
kernel version: 1.3.71
driver: tulip.c w/ Manabe's patches
card mode: 10baseT
------------------------------------------------
result: pings work, machine HANGS on first significant transfer!
        even a telnet will hang the machine.
------------------------------------------------

Please help! I will try 1.3.72 tonight to see if it works.
I really want to use a 1.3.x kernel.

I notice nobody has specifically said they had success with
a 1.3.67 - 1.3.71 kernel. And I have seen people saying that
TCP has some problems in that series.

Can anyone shed any light on this situation?

thanks,

Dwayne Fontenot

 
 
 

SMC EtherPower and Tulip driver

Post by Dwayne Jacques Fonten » Wed, 13 Mar 1996 04:00:00




Quote:>hello,

>AMD486DX120 PCI SiS 496/497 chipset.

>type of card: SMC
>chip on card: 21041
>kernel version: 1.2.13
>driver: tulip.c w/ Manabe's patches
>card mode: 10baseT
>------------------------------------------------
>result: success! very fast! 950KB/sec ftp on large files!
>------------------------------------------------

>type of card: SMC
>chip on card: 21041
>kernel version: 1.3.67, 1.3.71, 1.3.72
>driver: tulip.c w/ Manabe's patches
>card mode: 10baseT
>------------------------------------------------
>result: pings work, machine HANGS on first significant transfer!
>        even a telnet will hang the machine.
>------------------------------------------------
>Please help! I will try 1.3.72 tonight to see if it works.
>I really want to use a 1.3.x kernel.

Ok, I tried the latest Manabe tulip driver (0.68) and kernel 1.3.72
last night and had the same problem. I thought that maybe since 72 had
changes to the timer interrupt code it might solve the problem, but it
did not.

Once again, my system is AMD486DX120 PCI SiS 496/497 chipset. I have
PCI edge triggers set.

I then tried the new de4x5 driver in 1.3.72 and so far have had success.
The de4x5 driver is as fast as the tulip driver. I transferred a 6MB
file at about 980K/sec. No problems so far.

I would like to see whatever magic the de4x5 driver uses folded into the
tulip driver, since the de4x5 author cannot support cards other than DEC.

If anyone has any ways of finding out why the tulip driver hangs my system,
let me know. I would like to help, but am not a driver hacker.
Also, those disk checks on reboot after a hang are tiresome :-(

thanks,

Dwayne Fontenot

 
 
 

SMC EtherPower and Tulip driver

Post by sgin » Sat, 16 Mar 1996 04:00:00



> type of card: SMC
> chip on card: 21041
> kernel version: 1.3.71
> driver: tulip.c w/ Manabe's patches
> card mode: 10baseT
> ------------------------------------------------
> result: pings work, machine HANGS on first significant transfer!
>         even a telnet will hang the machine.
> ------------------------------------------------

> Please help! I will try 1.3.72 tonight to see if it works.
> I really want to use a 1.3.x kernel.

> I notice nobody has specifically said they had success with
> a 1.3.67 - 1.3.71 kernel. And I have seen people saying that
> TCP has some problems in that series.

> Can anyone shed any light on this situation?

If you happen to get an answer to this I would be interested as well.  I
am running kernel 1.3.73.

Thanks,
Steve

 
 
 

1. SMC EtherPower and Tulip driver


hello,

AMD486DX120 PCI SiS 496/497 chipset.

type of card: SMC
chip on card: 21041
kernel version: 1.2.13
driver: tulip.c w/ Manabe's patches
card mode: 10baseT
------------------------------------------------
result: success! very fast! 950KB/sec ftp on large files!
------------------------------------------------

type of card: SMC
chip on card: 21041
kernel version: 1.3.67
driver: tulip.c w/ Manabe's patches
card mode: 10baseT
------------------------------------------------
result: pings work, machine HANGS on first significant transfer!
        even a telnet will hang the machine.
------------------------------------------------

type of card: SMC
chip on card: 21041
kernel version: 1.3.71
driver: tulip.c w/ Manabe's patches
card mode: 10baseT
------------------------------------------------
result: pings work, machine HANGS on first significant transfer!
        even a telnet will hang the machine.
------------------------------------------------

Please help! I will try 1.3.72 tonight to see if it works.
I really want to use a 1.3.x kernel.

I notice nobody has specifically said they had success with
a 1.3.67 - 1.3.71 kernel. And I have seen people saying that
TCP has some problems in that series.

Can anyone shed any light on this situation?

thanks,

Dwayne Fontenot

2. Printer/Modem

3. Linux Driver for EIDE controller?

4. SMC EtherPower-tulip.o module help!

5. Embedded hardware kit

6. Apache SSL on HP

7. Help:SMC Etherpower/ 21040/tulip

8. SMC EtherPower 10/100 Tulip

9. SMC EtherPower 10/100 installation (tulip of de4x5)?