No longer boot from hard disk after defragment!

No longer boot from hard disk after defragment!

Post by Guillermo Alvar » Mon, 01 Sep 1997 04:00:00



When I began to need more swap space, I went to my DOS partition and ran
a Norton SPEEDISK to defragment and later create an additional swap
part. from the current space reserved to DOS (I didn't actually create
the partition, just defragmented the DOS area).  Now my i486 doesn't
boot Linux (Slackware 3.2, kernel 2.0.29) from the hard disk any more.
After the 5-sec delay I programmed, LILO decides correctly to load
Linux, but I only get the "Loading Linux" message on the screen and the
boot doesn't proceed.

I can only boot from the boot disk I generated in my last recompilation
of the kernel, several weeks ago.  Then the thing works and the contents
of the hard disk are perfectly accessible---it's the boot that
doesn't work.  I ran tests on the controller and hard disk (no errors),
restored the CMOS values, boot sector, and part. table from a backup,
restored /etc/lilo.conf and /vmlinuz from backup too, but the thing
still doesn't work.  The root filesystem has no errors when I e2fsck it
either.

Any idea on what's going on?  Maybe SPEEDISK went beyond the partition
limits and trashed part of Linux?  I'd prefer to avoid reinstalling
everything because it takes a *long* time using diskettes!

Thanks,
  Guillermo

 
 
 

No longer boot from hard disk after defragment!

Post by Bernt T. Hans » Wed, 10 Sep 1997 04:00:00



Quote:> Any idea on what's going on?  Maybe SPEEDISK went beyond the partition
> limits and trashed part of Linux?  I'd prefer to avoid reinstalling
> everything because it takes a *long* time using diskettes!

> Thanks,
>   Guillermo

Have you tried running lilo again after you boot off the floppy?
This should rewrite the boot sector and may clear up your problem...

Bernt.
--

Computer Systems/  - 235 Bellamy Road N., Scarborough -  phone: (416)431-6216
Analyst            - Ontario, Canada M1J-2L7 ----------  fax:   (416)431-2617
PGP Public Key fingerprint = CB 99 EC 07 DE F8 D5 8D  59 99 A5 E7 7E 7A 8C 9C

 
 
 

1. Hard disk no longer bootable - suspect Grub as the problem

I have a PC set up with swappable hardrives. For the last few months
now, I've been trying to reformat one of my 2 removeable hardrives and
to install some other kind of operating system, but for whatever
reason my system is having an extremely hard time detecting the disk,
and the thing is not bootable at all.  Although the BIOS does
eventually detect the disk, it takes about 10 times longer than normal
for it to get to the part where the OS should boot up, and even then,
.. nothing happens.

A while back, I attempted to install Linux Redhat 8 on this disk,
though after the install, the disk was no longer bootable. I had
chosen to install Grub as the boot loader, and I suspect that this may
have caused the problem, since while trying to boot up the disk in a
different computer the other day, I eventually got to a Grub boot
screen. This, I think, is very weird, since I have reformatted this
hardrive 3 using times already using Disk Administrator under Win2k.
I've deleted and recreated partitions, and re-formatted using both
NTFS and FAT32, but every time I try to set it up as a primary master
on ANY computer, .. it hangs. Setting it up as a slave is no problem
at all, however, since that's how I've been able to reformat under
Win2k.

I suspect that Grub is somehow hogging the MBR, and refusing to let
go. Please, .. anyone, .. how can I COMPLETEY remove Grub and properly
reformat this disk so that it can become bootable again?  I'm thinking
that perhaps some kind of low level format may be in order, but I
figured it'd be in my best interest to consult wiht the Linux experts
before I do more damage.

Thanks!
 - yvan

2. Help with HP 812C printer...

3. how to copy boot disk to hard disk

4. Ultra66 and SuSE 6.2 install

5. Boot disk won't mount hard disk as root filesystem

6. Networking problems / losing performance

7. HELP: DOS boot disk does not recognize my hard disk!!!

8. cold boot on lombard PB hangs

9. Boot Disk Cannot Find Hard Disk.

10. Dual Boot with Scovery Flash Disk and Hard Disk

11. R: Boot Disk Cannot Find Hard Disk.

12. Replacing Hard Disk - Copying Linux system to new Hard Disk ????