"fsck returned error code - reboot now" upon bootup

"fsck returned error code - reboot now" upon bootup

Post by steven dewayne walte » Mon, 29 Jan 1996 04:00:00



I am installing Linux for the first time.  It seems to have installed ok,
however, upon bootup I get the error "fsck returned error code - reboot
now".  I believe that it is related to my hard drive mounting as a read
only device.  When I bootup using LILO and I put the statement
"mount root = /dev/hdb2 rw" in my command line at the LILO prompt, the fsck
error does no appear and everything seems to work OK.  Is this the correct
method of fixing the problem and how can I permanently make my hdb2 a rw
device?  Any information would be greatly appreciated!!

Steve

--

       =====================================================================

       STEVEN D. WALTERS                         UNIVERSITY OF NORTH TEXAS

 
 
 

"fsck returned error code - reboot now" upon bootup

Post by Alan Reiche » Tue, 30 Jan 1996 04:00:00



: I am installing Linux for the first time.  It seems to have installed ok,
: however, upon bootup I get the error "fsck returned error code - reboot
: now".  I believe that it is related to my hard drive mounting as a read
: only device.  When I bootup using LILO and I put the statement
: "mount root = /dev/hdb2 rw" in my command line at the LILO prompt, the fsck
: error does no appear and everything seems to work OK.  Is this the correct
: method of fixing the problem and how can I permanently make my hdb2 a rw
: device?  Any information would be greatly appreciated!!

Steven,

When Linux boots, it first mounts the partitions as write-only in
order to do the file system check.  Once the check is accomplished
successfully, it will remount the partitions as read-write.  It is doing
as it should. Your command line statement is simply bypassing the file system
check, but the problem may still exist.  What happens if you reboot as it
says when the problem arises?

 
 
 

1. my PC doesn't reboot after "reboot" or "ctrl-alt-del"

: hi linuxers

: I use linux since 3 month on my new PC, and it doesn't reboot
: when I press ctrl-alt-del. Since the first version I used on
: this PC (maybe 1.3.20, dunno), It never worked. My PC does the
: shutdown, then stay locked. It sometimes "shutdown" the video
: card (my screen's led begin to flash, indicating it has lost
: the sync), but never goes further.

This happens to me sometimes but ss long as pressing
ctrl-alt-del unmounts all your drives and partitions, you can
safely press the restart button on your box.

Hasdi

2. Ext 3 and 17-pre4

3. startx returns errors "Not a declared device" or "Chipset string expected"

4. MP3 vs CD and Linux

5. GETSERVBYNAME()????????????????????"""""""""""""

6. Filtering Mail

7. FSCK RETURNED ERROR CODE -REBOOT NOW!

8. How can I install X softare ??

9. HELP: fsck returned error code - REBOOT NOW!

10. fsck returned error code - REBOOT NOW!

11. let "ls" not return an error code (in Makefile)

12. error code not return by "exec rsh"