ALSA master volume ignored!?

ALSA master volume ignored!?

Post by Barbaros » Tue, 03 Jun 2003 14:21:04



Has anyone come across the following problem before?

I am running Mandrake 9.0.  My motherboard has ProSavageDDR sound
onboard (VIA 8233 chipset).  I have tried to install the drivers for
my sound card.  I have downloaded and installed ALSA driver & utils,
version 0.9.0rc6.  I have unmuted the sound channels with alsamixer.
I get perfect sound, BUT changing the master volume control has no
effect!  PCM channel works fine, but I can set master to maximum or to
minimum, with no change to the sound output!

Any help to fix this problem would be greatly appreciated.

 
 
 

1. md 9.1, alsa: kmix volume works, xmms volume is ignored

using libalsa, I can listen to xmms even w volume under xmms fully
turned down, as long as the kmix volume is set high.  the libarts
driver gives no sound, and the liboss driver complains about
conflicts.  naturally, it would be nicer if I could control volume in
xmms.

does anyone have a similar experience and solution?  

/iaw

2. Sync on laptops

3. Can't change volume with ALSA, even as root

4. Firewall/route prob.

5. Alsa: Sound but no volume control

6. apache webserver question

7. Slightly OT: ALSA volume levels

8. Help.... Can't get PPP IPX Games to talk on net.

9. ALSA Volume under Redhat 8

10. mastering CDROM's from a Novell volume

11. Solaris Volume Manage Master Replica Database

12. ALSA modprobe works, but amixer thinks no alsa

13. alsa questions (alsa + arts = aplay_hangs)