DHCP not working

DHCP not working

Post by Charli » Sun, 31 Dec 1899 09:00:00



I just did a full install of RedHat 6.1.  I'm on a university network and
I'm DHCP client.  I don't think DHCP is working.  I know my network card
works fine.  I was running Mandrake 6.1 with this driver (tulip) and it
worked and the DHCP worked too.  Now when I startup RedHat it times out when
initializing eth0.  I haven't configured anything to be a DHCP client (cause
I never had to before).  So, is there something I should be looking for in
the startup to be running or something in a config file.

Thanx
Charlie

 
 
 

1. DHCP not working when booting, works after login

Hi everybody,

I got a confusing problem. I have about ten almost identically set up X
terminals which use DHCP to set up their networking. Two of them are
causing me headaches. When booting they request an IP address from the DHCP
server, the server makes the correct offer, but they prefer not to
acknowledge and instead time out, leaving their network configuration
undone. If I then login and run "/etc/init.d/networking start" they
suddenly behave correctly and take the offered IP address from the server.

dhcpd.conf looks like this:

----cut----
group {
        use-host-decl-names on;
        option routers 192.168.1.1;
        option broadcast-address 192.168.1.255;

        host hobbes {
                fixed-address hobbes;
                hardware ethernet 00:50:22:39:39:6C;
        }

        host kant {
                fixed-address kant;
                hardware ethernet 00:50:22:39:39:78;
        }

        host [...]

----cut----

All terminals have the same NIC (Realtek 8139) and run the same system and
kernel. Only those two are making trouble.

I'm running Debian unstable with dhcpd and dhcpcd (dhclient didn't work
neither).

I'd very much appreciate any hint on how I can find out what the problem is.

Thanks,

Severin

2. ATI Xpert2000 Pro

3. Redhat 6.1 with 3C905B adapter & DHCP not working

4. Fetchmail Help Requested

5. DHCP not working

6. USB 2.0 card?

7. DHCP not working with Linksy LNE100TX v4.1 (AMDtek AL985 Centaur-P)

8. Alpha Architecture Book Suggestions needed.......

9. pump+dhcp not working

10. DHCP not working....."Network is unreachable"

11. dhcp not working

12. DHCP not working in kernel 2.2.x, was OK in 2.0.36

13. DHCP not working with new 2.2.1 kernel