line printer daemon (lpd) dies/loses connection on large print

line printer daemon (lpd) dies/loses connection on large print

Post by nabb.. » Fri, 27 Feb 1998 04:00:00



hi,

There is a problem with redhat 5.0 on x86. I send a file to a remote
printer, At first the print job seems to be being send to the remote
server, then it loses connection, and using lpc>status I find that there
is no daemon present.

lpc> status
print236:
        queuing is enabled
        printing is enabled
        7 entries in spool area
        sending to xxxx.xxxx.com

Now, I wait few minutes, look in the /var/log/messages, see messages
as this:

Feb 26 00:20:44 localhost lpd[286]: print236: lost connection
Feb 26 00:24:19 localhost lpd[1006]: print236: lost connection
Feb 26 00:36:08 localhost PAM_pwdb[1996]: (su) session opened for user root by
nasser(uid=0)
Feb 26 00:38:12 localhost lpd[1999]: print236: lost connection

Look at lpc again:

lpc> status  
print236:
        queuing is enabled
        printing is enabled
        7 entries in spool area
        no daemon present
lpc>

I do lpc>restart print236
I see the sending to .... message come up again, and few minutes later
the same story repeat.

Any ideas where I can look more for more info? is the /var/log/messages
the only place where errors go to on Linux?

it is very annoying when one can not print large files from Linux, this
forces me to have to reboot my machine and boot into NT to be able to
print this one file.

thanks,
Nasser

 
 
 

1. Lost lpd daemon - no printing

Anyone can help?  I read the Printing-HOWTO;  set up the spooler
files accordingly.  Printcap is also done according to the howto.
When I lpr, the output spools but the lpd daemon does not pick
up the spooler to the printer.  When I ps ax, the lpd is sitting
there.

Printer port is confirmed by direct output from ghostscript.  I read
in the howto that linux has a history of this problem and the author
is not sure why.  I added the ifconfig lo localhost; rout add localhost
to the net.??? file in order to have the host refer to itself, as suggested
by the howto, but still no printing.

Its five in the morning, I have been at it for several days, and
I am at a loss what to do.  My kernel is 1.159 on the Slackware 2.1
release.  I checked the ftp.cdrom.com for another version of lpd, but
the file was dated 1992 -- I assume slackware disks have later
versions.

BTW, I have no other problems with the system.  Linux is beautiful...

thanx in advance,
    ---b.

-----------------------------------------------------------peace.

2. cfgmgr (configuring devices added after boot)

3. lpd: lost connection leaving print jobs in spool area

4. Sparc Linux

5. Xcd print server loses connection with lpd.

6. spea video7 vega+, LINUX driver

7. Problem of Solaris 2.4 printing with Line Printer Daemon

8. KERNEL: export symbols from loadable driver?

9. Printing: lpd loses print jobs

10. lpd daemon keeps dying, help please??

11. PC-NFS, printing, bannerpage. die.die.die

12. Hung Print Jobs: Printer Driver for DataProducts Line Printer

13. lpd -- Print job that won't die