Make problems re-compiling kernel 2.0.34-0.6

Make problems re-compiling kernel 2.0.34-0.6

Post by Jones29 » Wed, 29 Jul 1998 04:00:00



Would someone please explain the following messages:

make[1] as86: Command not found
make[1] ***[bootsect.o] Error 127
make[1] Leaving directory '/usr/src/linux-2.0.34/arch/i386/boot'
make *** [zImage] Error 2

Trying to re-compile kernel for 2.0.34-0.6 with the following updates:
initscripts-3.67-1.i386.rpm
kernelcfg-0.4-8.i386.rpm

The updated rpm packages noted above were successfully installed prior to
issuing the following commands in sequence:

make config
make dep
make clean
make zImage

Thanks for your help!

Jerry

 
 
 

Make problems re-compiling kernel 2.0.34-0.6

Post by Rosie Scenari » Sat, 01 Aug 1998 04:00:00



> Would someone please explain the following messages:

> make[1] as86: Command not found

Install the bin86 package. This package contains the assembler.

 
 
 

Make problems re-compiling kernel 2.0.34-0.6

Post by Richard S. Lumpki » Tue, 04 Aug 1998 04:00:00






> > > Would someone please explain the following messages:

> > > make[1] as86: Command not found

> > Install the bin86 package. This package contains the assembler.

> If Jones2932's problem is similar to the one I have, then the bin86 package is
> already installed. The Makefile in /usr/src/linux/arch/i386/boot seems a bit
> strange to me, it defines AS86 = AS86 with the following switches -0 -a -o.
> Either there's a broken symbolic link between /bin/as and as86 or ... beccause
> I can't find any program called as86 on my fresh installation of RH 5.1...

Did you install the complete set of development tools?  The more I read
the less likely I think I'll bother with the RH5.1 upgrade.  Also in an
unrelated note to your stated problem, you might want to move on to
2.0.35 rather than recompile an out of date kernel.

------------------------------------------------------------------------
Richard S. Lumpkin, Ph.D.                            Associate Professor
Department of Chemistry                                     256-890-6365
University of Alabama in Huntsville                     fax 256-890-6349
Huntsville, AL 35899                          http://chromophore.uah.edu
------------------------------------------------------------------------

 
 
 

Make problems re-compiling kernel 2.0.34-0.6

Post by Jones29 » Fri, 07 Aug 1998 04:00:00


Thanks to Rosie :-) I found that I had not installed the assembler (bin86).
Made the incorrect assumption that the compiler package included the assembler.
Am finally "up and running" after extended frustration with the 5.1 install.
The earlier RedHat installs went very, very smoothly compared to this one!

Jerry