NetAudio Problems (Xpilot + NAS + RedHat Linux 3.03)

NetAudio Problems (Xpilot + NAS + RedHat Linux 3.03)

Post by Richard S. Smi » Wed, 11 Sep 1996 04:00:00



Sorry if this is an FAQ, but I can't seem to get Netaudio to work with
Xpilot.  My versions are as follows:

- xpilot-3.5.1

- nas-1.2p4

- Red Hat Linux version 3.03

- gcc version 2.7.2.1

- X11R6 (XFree86)

I suspect the culprit is Xpilot because NAS utilities (like audemo) work
perfectly and other NAS-supporting games (like acm) work as well.  I
uncommented the NCD_SOUND stuff in Local.config and set the include and
library paths correctly.  Clean compile - no sound.

I thought NCD and NetAudio were the same thing, or at least that they are
compatible with each other.  Am I mistaken?

So what gives?  Any help on this will be much appreciated.

--
+---------------------------------------------------------------+

| Progress(tm) 4gl v[67] Developer / Los Gatos, California, USA |
| PROGRESS FAQ: ftp://ftp.netcom.com/pub/rs/rsmith/progress-faq |
+---------------------------------------------------------------+

 
 
 

NetAudio Problems (Xpilot + NAS + RedHat Linux 3.03)

Post by Bert Gijsbe » Wed, 11 Sep 1996 04:00:00



Quote:>I suspect the culprit is Xpilot because NAS utilities (like audemo) work
>perfectly and other NAS-supporting games (like acm) work as well.  I
>uncommented the NCD_SOUND stuff in Local.config and set the include and
>library paths correctly.  Clean compile - no sound.

Dunno (never use sound) but maybe you also have to uncomment the line
containing ServerSound in Local.config?  Please report your results.

If this does help then we may want to get sound in the server turned on
as soon as one of NCD_SOUND, RPLAY_SOUND etc. is defined.

Bert

 
 
 

NetAudio Problems (Xpilot + NAS + RedHat Linux 3.03)

Post by Mark Boyn » Wed, 11 Sep 1996 04:00:00




> >I suspect the culprit is Xpilot because NAS utilities (like audemo) work
> >perfectly and other NAS-supporting games (like acm) work as well.  I
> >uncommented the NCD_SOUND stuff in Local.config and set the include and
> >library paths correctly.  Clean compile - no sound.

> Dunno (never use sound) but maybe you also have to uncomment the line
> containing ServerSound in Local.config?  Please report your results.

> If this does help then we may want to get sound in the server turned on
> as soon as one of NCD_SOUND, RPLAY_SOUND etc. is defined.

Also, make sure your `sounds' configuration file is using sounds that
you actually have.  (see doc/README.sounds)

xpilot will only play sounds when you connect to a server that
supports audio events.

--
To escape the grip of a crocodile's jaws, push your thumbs into its
eyeballs -- it will let you go instantly.

 
 
 

NetAudio Problems (Xpilot + NAS + RedHat Linux 3.03)

Post by Alex Horn » Fri, 13 Sep 1996 04:00:00




Quote:> Sorry if this is an FAQ, but I can't seem to get Netaudio to work with
> Xpilot.  My versions are as follows:

> - xpilot-3.5.1

> - nas-1.2p4

> - Red Hat Linux version 3.03

> - gcc version 2.7.2.1

> - X11R6 (XFree86)

I had the same problems, it is the buckets that do it. Try playing a bucket
from audemo (not just playing a sample) that crashes for me. The solution is
apparently to compile NAS without the BSD sockets defines. (From the NAS
mailing list)

Alex.
--
++ Alex Hornby | http://www.users.zetnet.co.uk/ahornby | PGP ++

 
 
 

1. Linux RedHat 3.03 Problems

Hi,

Does anyone knows howto handle the "/etc/passwd" file ?

My problem:
I make a complete new installation of Redhat 3.03, but
know I'm not able to make an ftp to my computer, except of an Anonymous
login.

Can Anyone post me a example-line (see problem above) of the
passwd-file.
for following 2 persons:

1) The default-directory must be /
Name: user1
home-directory: /home/user1

2) The default-directory must be /home/user2
Name: user2
home-d.: /home/user2

Thanks for your help

Patrick

2. WANTED: Beta testers for g77 graphics package

3. NAS (netaudio) on UDB?

4. Using Sed to swap two lines in a file

5. HELP: RedHat 3.03 CD install problem

6. normal login prompt....

7. Installing ftape on RedHat 3.03 Linux

8. RFS sources and docu

9. RedHat Linux Unleashed (3.03) Manual Instl?

10. RedHat 3.03 and Comtrol RocketPort Driver Install Problem

11. Lilo problems with upgrade to Redhat 3.03 and Kernel 2.0

12. Redhat 3.03, aha2940, LILO problem.

13. Advanced Question - eth0 problem (Redhat 3.03)