Printing problem: To Apple Laser Writer II, printcap file?

Printing problem: To Apple Laser Writer II, printcap file?

Post by Sha » Fri, 09 Aug 1996 04:00:00



Hi there,

I am having problem using "lpr" to print to an apple laser writer II locally.
 The "ls > /dev/ttyS1" command works fine.  So I think it is the printcap
file problem.  The printer is connected to com2 port.  Does anyone have a
working printcap file?

Thanks,
Shan

 
 
 

Printing problem: To Apple Laser Writer II, printcap file?

Post by Jay Thorn » Sun, 11 Aug 1996 04:00:00



> Hi there,

> I am having problem using "lpr" to print to an apple laser writer II locally.
>  The "ls > /dev/ttyS1" command works fine.  So I think it is the printcap
> file problem.  The printer is connected to com2 port.  Does anyone have a
> working printcap file?

> Thanks,
> Shan

If that command worked fine, then the Laserwriter is set to
diablo 630 emulation ie, no postscript.  THere is a switchpack
that will let you use the postscript on the serial port.

--
Jay Thorne                http://net.result.com/
President, The Net Result Systems * Services  Telephone:(604) 220 2504
WWW & Internet Systems Consultant.

 
 
 

Printing problem: To Apple Laser Writer II, printcap file?

Post by Andrew Bir » Mon, 12 Aug 1996 04:00:00





> > Hi there,

> > I am having problem using "lpr" to print to an apple laser writer
II locally.
> >  The "ls > /dev/ttyS1" command works fine.  So I think it is the printcap
> > file problem.  The printer is connected to com2 port.  Does anyone have a
> > working printcap file?

> > Thanks,
> > Shan
> If that command worked fine, then the Laserwriter is set to
> diablo 630 emulation ie, no postscript.  THere is a switchpack
> that will let you use the postscript on the serial port.
> --
> Jay Thorne                http://net.result.com/
> President, The Net Result Systems * Services  Telephone:(604) 220 2504
> WWW & Internet Systems Consultant.

look at the Printing-HOWTO - it explains everything although I still
can't find the octal bits to set xon/xoff flowcontrol

lp|lp0|Epson FX Serial on Local:\
   :lp=\dev\cua1:\
   :sd=\usr\spool\lp0:\
   :lf=\usr\spool\lp0\log:\
   :br#9600:\
   :mx#0:\
   :fc#0177777:\
   :fs#0455:\
   :xc#0177777:\
   :xs#0:\
   :sh

This is mine for 9600/7/e/1

 
 
 

1. Net print to Apple Laser Writer

I am running Linux from the Slackware 3.0 distribution and I'm having
some weird problems printing to a printer served to our Novell network.

I can send postscript data to an HP LJ4 perfectly OK, however, when
sending the same postscript data to an Apple Laser Writer Pro connected
to the same network, the printer merely accepts the data and then resets
as opposed to actually printing the document. The two printers are setup
identically in the /etc/printcap file (except they have different spool
directories and remote names!)

Does anyone have an idea as to what is going on ... perhaps the
postscript files has some hidden codes in it that the Apple does not like
whereas the HP is able to ignore/handle them??

Thanks in advance for any help

Dave Powell

2. HELP: Looking for Unix Groups in MI

3. /etc/printcap for apple laser select 310

4. Erratic xclock

5. apple laser writer plus

6. hfs-zip

7. Apple Personal Laser Writer & Linux

8. lookup hosts

9. ditroff filter for Apple Laser-Writer

10. Spooling Apple Laser writers with a Linux server

11. Apple Laser Writer on Sparc 20

12. aix and apple laser writer NT

13. Linux & Apple Laser Writer Select 360?