Help: Linux won't recognize my modem

Help: Linux won't recognize my modem

Post by Zhongxia YU » Sun, 12 Oct 1997 04:00:00



Hi,

I'm having problems to make linux recognize my modem. I'm using RedHat
4.2 (kernel 2.0.30). My modem is Compaq 336-VSC (internal) with irq=3
and address=0x2f8 (it's on COM2 at Win95). When starting kermit in
linux and doing a "set line /dev/cua1", the following message was
displayed:
               /dev/cua1 is not a terminal device
               Sorry, can't open connection: /dev/cua1

This happens even when I made sure that the /dev/cua1 is set with
correct parameters, i.e. "setserial /dev/cua1 irq 3 addr 0x2f8 uart
16550A".  Doing an "ls -l /dev/cua*" gives following infomation:

        crw-rw----  1 root    uucp     5, 64 Oct 11 13:37 cua0
        crw-rw----  1 root    uucp     5, 65 Dec 31  1979 cua1
        crw-rw----  1 root    uucp     5, 66 Dec 31  1979 cua2
        crw-rw----  1 root    uucp     5, 67 Dec 31  1979 cua3

Any ideas? I've already been tweaking this for quite along time and almost
give up... ;-(  Any hint will be greatly appreciated.

Thanks.

--

School of Computer Science     WWW: http://www.cs.mcgill.ca/~zxyuan
McGill University              Phone(home):   (514)845-4293
Montreal, QC                   Phone(office): (514)398-7086

 
 
 

1. Help: Linux won't recognize my modem

Hi,

I'm having problems to make linux recognize my modem. I'm using RedHat
4.2 (kernel 2.0.30). My modem is Compaq 336-VSC (internal) with irq=3
and address=0x2f8 (it's on COM2 at Win95). When starting kermit in
linux and doing a "set line /dev/cua1", the following message was
displayed:
               /dev/cua1 is not a terminal device
               Sorry, can't open connection: /dev/cua1

This happens even when I made sure that the /dev/cua1 is set with
correct parameters, i.e. "setserial /dev/cua1 irq 3 addr 0x2f8 uart
16550A".  Doing an "ls -l /dev/cua*" gives following infomation:

        crw-rw----  1 root    uucp     5, 64 Oct 11 13:37 cua0
        crw-rw----  1 root    uucp     5, 65 Dec 31  1979 cua1
        crw-rw----  1 root    uucp     5, 66 Dec 31  1979 cua2
        crw-rw----  1 root    uucp     5, 67 Dec 31  1979 cua3

Any ideas? I've already been tweaking this for quite along time and almost
give up... ;-(  Any hint will be greatly appreciated.

Thanks.

--

School of Computer Science     WWW: http://www.cs.mcgill.ca/~zxyuan
McGill University              Phone(home):   (514)845-4293
Montreal, QC                   Phone(office): (514)398-7086

2. multiple telnet session on a dumb terminal

3. RPC program

4. HELP: Yggdrasil fall 94 won't recognise my modem

5. Linux boot/root.

6. HELP: Yggdrasil fall 94 won't recognised my modem

7. help of ethernet card

8. Linux won't recognize my modem

9. Linux won't recognise my internal modem.

10. HELP: pppd won't talk to modem, and won't link up with ISP

11. 'Toolkit for Linux' won't recognize CDROM

12. HELP: Linux instal won't recognize adaptec SCSI card