redhat rpm error: can't install or update rpms

redhat rpm error: can't install or update rpms

Post by Daniel A. Christenso » Tue, 07 Oct 1997 04:00:00



  has anyone ever setup a network printer attached to a Novell server to a
linux machine?  

   Any ideas would be appreciated.

         thanks!

 
 
 

redhat rpm error: can't install or update rpms

Post by James Tappi » Tue, 07 Oct 1997 04:00:00



> my problem:  when i run the x rpm, select the package i want to install or

                                 ^ You mean glint?

Quote:> update, then press the old update button, the progress-bar dialog appears
> for a split second, and the package remains in the rpm window.  installing
> or updating some programs disappear from rpm after they've been installed.

Best guess: Failed dependencies.

Glint fails singularly gracelessly. I suggest you try using
rpm -Uvh <path name of package rpm>
at the command line. This will give you messages telling you what is
going wrong if it fails.

--
+------------------------+-------------------------------+---------+
| James Tappin,          | School of Physics & Astronomy |  O__    |

| Ph: 0121-414-6462. Fax: 0121-414-3722                  |         |
+--------------------------------------------------------+---------+

 
 
 

redhat rpm error: can't install or update rpms

Post by Brian McCaule » Tue, 07 Oct 1997 04:00:00



Quote:>   has anyone ever setup a network printer attached to a Novell server to a
> linux machine?

Yeah, no problem.  Get nprint working (see IPX-HOWTO) then write a lpr
"input filter" that calls nprint.  Here's mine:

#!/bin/sh
exec nprint -n -U wcl-l -S WOLFSON_SRV1 -q WCL_PROG_3 -

Where "wcl-l" is a non-password account on Novell server WOLFSON_SRV1
restricted to connecting from the the IPX address of the Linux box.

--

 .  _\\__[oo       from       | Phones: +44 121 471 3789 (home)

.  l___\\    /~~) /~~[  /   [ | PGP-fp: D7 03 2A 4B D8 3A 05 37...
 # ll  l\\  ~~~~ ~   ~ ~    ~ | http://wcl-l.bham.ac.uk/~bam/