Uno! Smartmedia - no space left on device

Uno! Smartmedia - no space left on device

Post by Michae » Fri, 06 Sep 2002 13:47:38



Hello,

I'm running Red Hat 7.2 and using a USB port for a Uno! Smartmedia
removable card reader (128Mb).  It is well supported under Linux. It
mounts properly and I can read and write to it without problem.  "df"
shows:

Filesystem            1k-blocks        Used        Available
Use%        Mounted on

/dev/sda1               127936           18736      109200
15%          /mnt/smartmedia

However, when I try to write more data to it I get "no space left on
device" even though it appears to only be fif* percent full. Any idea
why this would happen?

Mike

 
 
 

Uno! Smartmedia - no space left on device

Post by Barry Simpl » Sat, 07 Sep 2002 05:35:53


Try 'df -i' to see if you are out of i-nodes.

> Hello,

> I'm running Red Hat 7.2 and using a USB port for a Uno! Smartmedia
> removable card reader (128Mb).  It is well supported under Linux. It
> mounts properly and I can read and write to it without problem.  "df"
> shows:

> Filesystem            1k-blocks        Used        Available
> Use%        Mounted on

> /dev/sda1               127936           18736      109200
> 15%          /mnt/smartmedia

> However, when I try to write more data to it I get "no space left on
> device" even though it appears to only be fif* percent full. Any idea
> why this would happen?

> Mike


 
 
 

Uno! Smartmedia - no space left on device

Post by Michae » Sat, 07 Sep 2002 09:41:11



> Try 'df -i' to see if you are out of i-nodes.

Thanks for your response.  I did "df -i" on the device:

Filesystem   Inodes  IUsed  IFree IUse% Mounted on
/dev/sda1      0          0         0       -          /mnt/smartmedia

I'm not sure what this all means as I only have a vague idea of
what inodes are. Also, I use this device to transfer files among
2 Linux boxes and a Windows box.

Can you give me an idea of what to do from here?

Thanks,
Mike

 
 
 

1. Uno SmartMedia USB card reader: plugged in but SCSI device does not appear.

On Mandrake 8.2, I've plugged in a Uno OmniFlash SmartMedia card reader. It
shows up as an attached device here:

/mnt $ cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: LITE-ON  Model: LTR-24102B       Rev: 5S57
  Type:   CD-ROM                           ANSI SCSI revision: 02
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: OEI-USB  Model: SmartMedia       Rev: 1.00
  Type:   Direct-Access                    ANSI SCSI revision: 02

but the corresponding /dev/sc* does not appear:

/mnt $ l /dev/scd0
lr-xr-xr-x    1 root     root           31 Aug 19 08:34 /dev/scd0 ->
scsi/host0/bus0/target0/lun0/cd
/mnt $ lar /dev/scsi/
/dev/scsi/:
total 0
drwxr-xr-x    1 root     root            0 Jan  1  1970 host0/
drwxr-xr-x    1 root     root            0 Jan  1  1970 host1/

/dev/scsi/host0:
total 0
drwxr-xr-x    1 root     root            0 Jan  1  1970 bus0/

/dev/scsi/host0/bus0:
total 0
drwxr-xr-x    1 root     root            0 Jan  1  1970 target0/

/dev/scsi/host0/bus0/target0:
total 0
drwxr-xr-x    1 root     root            0 Jan  1  1970 lun0/

/dev/scsi/host0/bus0/target0/lun0:
total 0
brw-rw----    1 adam     cdwriter  11,   0 Jan  1  1970 cd

/dev/scsi/host1:
total 0
drwxr-xr-x    1 root     root            0 Jan  1  1970 bus0/

/dev/scsi/host1/bus0:
total 0
drwxr-xr-x    1 root     root            0 Jan  1  1970 target0/

/dev/scsi/host1/bus0/target0:
total 0
drwxr-xr-x    1 root     root            0 Jan  1  1970 lun0/

/dev/scsi/host1/bus0/target0/lun0:
total 0

How do I make /dev/scd1 appear so I can put it in /etc/fstab and mount it?

Thanks,
Adam

2. Ramdisk ... changed? ... broken?

3. How to Unmount and Remove UNO SmartMedia card reader

4. Apache won't output embedded plugin to Netscape

5. USB Uno Smartmedia woes w/Red Hat 7.2

6. Learning about math/algebraic functions (Bourne shell/SCO)

7. No space left on device (although space exists)

8. forcing 100 Mbps SMC card with EPIC driver into 10 mbps using epic-diag

9. How to make space (no space left on device)

10. EXT2-fs error (device 8/3) and ld: no space left on device

11. "semget: No space left on device"

12. No space left on device for /var filesystem

13. sort: write error while sorting: No space left on device??