(3rd Post..) LILO Boot floppy/ Accessing DOS files...

(3rd Post..) LILO Boot floppy/ Accessing DOS files...

Post by Alfred E. Gree » Wed, 11 Jun 1997 04:00:00



I'm running Slackware 3.1 w/LINUX 2.0 kernal on a AMD 5x86 133mhz CPU.

My Win95 partition is on /dev/hda and Linux resides on /dev/hdb.

I seem to be having problems booting using LILO from my floppy bootdisk.
The kernal unpacks fine but hangs near the end of the boot sequence. The
line that comes to mind is VFS(Dos support etc). I'm confident LILO is
running because I have seen  the LILO msg pass across the screen.

I suppose the floppy has gotten corrupted*shrug*?

Frankly, I'd like to use LILO from my harddrive so that I may avoid
future problems. Any suggestions:)

Question 2..

What is the most efficient and easiest method of gaining access to MSDOS
files w/LINUX? During my install, I mistakenly chose not permanently
mount the DOS partition;(

I want to access my Win95 files via LINUX. A permanent fix/mount would
be preferred..

--
Alfred

--
Alfred

"...then the day came when the risk to remain tight in a
bud was more painful than the risk it took to blossom."

                                          Anois Nin      
____________________________________________________________

PERSONAL
http://www.eng.fsu.edu/~green
____________________________________________________________

 
 
 

(3rd Post..) LILO Boot floppy/ Accessing DOS files...

Post by dj.benn.. » Wed, 11 Jun 1997 04:00:00


Re your second question

Look at /etc/fstab. This file is used at booting to set up the partitions. You could try adding a line in there. The line should be similar to the one that mounts your current Linux dirve /partition

Presuming you WIN95 resides as iether as the first disk or first parition you  will need something like

                /dev/hda1          or                /dev/hdb1

under the partition type you need to enter vfat, this will enable you to use WIN 95 long file names (otherwise you could use msdos.

Hope this helps

Dave Bennett

 
 
 

(3rd Post..) LILO Boot floppy/ Accessing DOS files...

Post by Tim Curr » Wed, 18 Jun 1997 04:00:00




Quote:> I'm running Slackware 3.1 w/LINUX 2.0 kernal on a AMD 5x86 133mhz CPU.

> My Win95 partition is on /dev/hda and Linux resides on /dev/hdb.

[deletia]
> Frankly, I'd like to use LILO from my harddrive so that I may avoid
> future problems. Any suggestions:)

  Run liloconfig and set it up so that LILO is installed in the MBR of hda.
Be aware that the first OS defined is the defualt to boot, unless you go into
/etc/lilo.conf and change it manually.

Quote:> Question 2..

> What is the most efficient and easiest method of gaining access to MSDOS
> files w/LINUX? During my install, I mistakenly chose not permanently
> mount the DOS partition;(

> I want to access my Win95 files via LINUX. A permanent fix/mount would
> be preferred..

  Study /etc/fstab and add a line for your Win95 partition. Don't forget
to add a directory to use as a mount point (i.e. /DOS or something). If
you want to see Win95 long file names, use VFAT as the filesystem type.
  Once you've made the change to the file, you can use
    mount -ta VFAT
  to mount all VFAT partitions in /etc/fstab. Likewise, you can use
    umount -ta VFAT
  to unmount all VFAT partitions. A word of warning: don't do
    umount -a
  I'm not sure what it'll do, but it probably won't be pretty. : )

You may need to re-build the kernel to support VFAT, so don't be surprised
if it doesn't work right the first time. : )

-Tim

 
 
 

1. Can't create lilo boot floppy for 3rd SCSI disk but can boot it

I have Linux 1.2.8 installed on a IDE /hda2 as root with 2 SCSI disk
drives with MS-DOS and some additional linux partitions on a AHA1542.
I have now got a new SCSI HD and copied all the Linux onto the last SCSI
hard disk (ID:3), hoping to delete the IDE stuff. When I came to
install LILO on a boot floppy, it came up BIOS drive 0x83 may not be
accessible 3 times.

When I boot, I just get garbage but I did manage to re-mount the
/hda2 to / with a SCSI kernel recovery disk and created a SCSI boot
floppy and that works OK. Trouble is that I cannot install LILO
and I will need to change things in the future once I have deleted
my IDE partition. The LILO DOCs do not give specific guidance

Any ideas?

******************************************************


* On the Web: http://www.wlv.ac.uk/~cm4272/home.html *
* "Our Hamburgers are made with beef" - McDonald's   *
******************************************************

2. What Unix Command???

3. LILO error: Can only boot from floppy, LILO will only start dos not linux

4. Re-install GRUB on dual boot PC

5. LILO boot floopy/Accessing DOS files..

6. Trident 8900CL/8900D

7. LILO: Booting Dos from 3rd SCSI-Drive?

8. how to write codepages for 2.2

9. Can't boot Win95 from LILO or DOS from floppy

10. Boot the 3rd HD from Boot Manager/LILO

11. Linux floppy won't boot, DOS floppy will

12. How to Uninstall LILO -o How to boot DOS once LILO is installed?

13. Make the boot floppy boot dos?