Upgrading to XFree86-3.3

Upgrading to XFree86-3.3

Post by Gary Hodge » Thu, 14 Aug 1997 04:00:00



OK, I'm just about nearly exactly perfectly clear on what I need to
do to upgradefrom XFree86-3.2 to XFree86-3.3.  If someone would please
take just a moment to clear up a couple points where I'm unclear.

First, I have downloaded the following files:

XFree86-100dpi-fonts-3.3.1-1.i386.rpm
XFree86-3.3.1-1.i386.rpm
XFree86-75dpi-fonts-3.3.1-1.i386.rpm
XFree86-8514-3.3.1-1.i386.rpm
XFree86-AGX-3.3.1-1.i386.rpm
XFree86-I128-3.3.1-1.i386.rpm
XFree86-Mach32-3.3.1-1.i386.rpm
XFree86-Mach64-3.3-1.i386.rpm
XFree86-Mach64-3.3.1-1.i386.rpm
XFree86-Mach8-3.3.1-1.i386.rpm
XFree86-Mono-3.3.1-1.i386.rpm
XFree86-P9000-3.3.1-1.i386.rpm
XFree86-S3-3.3.1-1.i386.rpm
XFree86-S3V-3.3.1-1.i386.rpm
XFree86-SVGA-3.3.1-1.i386.rpm
XFree86-VGA16-3.3.1-1.i386.rpm
XFree86-W32-3.3.1-1.i386.rpm
XFree86-XF86Setup-3.3-1.i386.rpm
XFree86-XF86Setup-3.3.1-1.i386.rpm
XFree86-devel-3.3.1-1.i386.rpm
XFree86-libs-3.3.1-1.i386.rpm

I am upgrading to v3.3 for the benefit of my video card - ATI PROTURBO
PC2TV Mach_64.  Questions:

(1) Which of the above files do I need?

(2) The command to run is <rpm -Uvh XFree86*.rpm>?????

(3) Which directory should I run the above command in?  Does it matter?

Regards,
Gary Hodges

 
 
 

1. Upgraded to XFree86-3.2-9 and can't get xdm to work

I recently installed the XFree86-3.2-9.rpm file and can not get xdm to
work properly.  It did install the xdm file in my /etc/pam.d/
directory, but once I login xdm just restarts.  The following are the
error messages:

/var/log/xdm-error.log

XBanner: Could not get the font, using 'fixed'
AUDIT: 236 Xaccel: client 2 rejected from local host

~/.xsession-errors

/etc/X11/xdm/Xsession: freetemp: command not found
~/.xsession: xterm: command not found
~/.xsession: exec: twm: not found
Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server
www: cannot connect to X server :0
Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server
application-specific initialization failed: couldn't connect to
display ":0"

XFree86-3.2-9 installed this /etc/X11/xdm/Xsession file:

#!/bin/bash -login

case $# in
1)
        case $1 in
        failsafe)
                exec xterm -geometry 80x24-0-0
                ;;
        esac
esac

freetemp

startup=$HOME/.xsession
resources=$HOME/.Xresources

if [ -x "$startup" ]; then
        exec "$startup"
else
        if [ -f "$resources" ]; then
                xrdb -load "$resources"
        fi
        exec xsm
fi

The final program called is xsm and the man page says with xsm your
xsession file needs to be rewritten.  When I renamed my .xsession
file, I received the same errors.  .Xauthority appears correct,
although once after a failed session it zeroed out.  There is a cookie
in the /etc/X11/xdm/authdir/authfiles directory.

Any assistance is appreciated in advance.
Thomas Warlick

Open computing forever...

2. Getting mail from a pop acount

3. Upgrading from XFree86 3.3.1 to XFree86 3.3.2

4. Specialix driver

5. Upgrade to XFree86-3.1 HOWTO or FAQ?

6. Quick Help Please....

7. Can't start X-window after upgrading to XFree86-3.3.5 rpm

8. where to get TCP/IP for SCO Unix 3.2v4

9. How easy to upgrade from XFree86 2.1.1 to XFree86 3.1

10. XFree86.4.0.3: Cannot find fonts after upgrade from XFree86.4.0.2

11. ET4000/W32p - Upgrade to XFree86 3.3 fails

12. Upgraded to XFree86 4.0.1, xterm locks up mouse and kb

13. Need Help Upgrading from XFree86 3.2Abeta to 3.3