AGP problems

AGP problems

Post by Ro » Tue, 01 Dec 1998 04:00:00



check out http://www.x11.org
follow the link to XSuse and check their list of supported cards.
If you find one..make sure to download their version of xf86config
too!
-Rob

>Dear Friends,

>I have a Creative Riva TNT AGP Card, how can I config it to run X-Windows..... ????
>I am using Red Hat 5.2......Help pls......!!!

>How can I get the newest version of Xfree 3.3.3 ???

 
 
 

AGP problems

Post by Limestone Cowbo » Wed, 02 Dec 1998 04:00:00


A very big download perhaps


    try ftp.xfree86.org

        How can I get the newest version of Xfree 3.3.3 ???

 
 
 

1. agp problem: cannot write combine agp aperture

I have an MSI 8831 video card (geforce 2) and a FIC AD11 mom board (AMD
761). I'm running Slackware 8.0 (XFree86 4.1.0) with a 2.4.12 kernel
that I compiled (mtrr support is compiled in). I'm using the nvidia
1.0-1541 driver.

When agpgart isn't compiled in, after I startx "dmesg | grep NVRM" yields:
        NVRM: loading NVIDIA kernel module version 1.0-1541
        NVRM: *** Cannot WriteCombine the AGP Aperture

"cat /proc/nv/card0" yields:
        ----- Driver Info -----
        NVRM Version: 1.0-1541
        ------ Card Info ------
        Model:        GeForce2 GTS
        IRQ:          10
        Video BIOS:   03.15.01.00
        ------ AGP Info -------
        AGP status:   Disabled
        AGP Driver:
        Bridge:       Generic AMD
        SBA:          Supported [disabled]
        FW:           Supported [disabled]
        Rates:        4x 2x 1x  [-]
        Registers:    0x0f000217:0x00000000

When agpgart is compiled in, after I startx, "dmesg | grep agpgart" yields:
        Linux agpgart interface v0.99 (c) Jeff Hartmann
        agpgart: Maximum main memory to use for agp memory: 203M
        agpgart: Detected AMD 761 chipset

and "dmesg | grep NVRM" yields:
        NVRM: loading NVIDIA kernel module version 1.0-1541
        NVRM: AGPGART: unknown chipset
        NVRM: AGPGART: unable to set MTRR write-combining

        NVRM: AGPGART: aperture mapped from 0xd0000000 to 0xd598f000
        NVRM: AGPGART: mode 4x
        NVRM: AGPGART: allocated 16 pages

and /proc/nv/card0 says:
        ...
        ------ AGP Info -------
        AGP status:   Enabled
        AGP Driver:   AGPGART
        Bridge:       Generic AMD
        SBA:          Supported [disabled]
        FW:           Supported [disabled]
        Rates:        4x 2x 1x  [4x]
        Registers:    0x0f000217:0x00000104

Does anyone have any ideas? Is this just a configuration problem? Am I
having a hardware problem?

Much thanks,
Jason

2. RS 6000 problem with channel adapter direct to 390

3. nvidia agp problem: cannot writecombine agp aperture

4. Questions on amd daemon

5. Diamond Viper 550 - AGP Problems w/RH 5.2

6. protecting against SYN flooding

7. Viper 330 AGP Problem

8. how to setup isdn

9. AGP problem with Intel E7505 chipset and nvidia quadro4 750xgl

10. Another AGP problem

11. Sis 6326 AGP - Problem with X

12. nvidia agp problems

13. strange IRQ/AGP problem