lpd doesn't work properly

lpd doesn't work properly

Post by John Reumann SET.R » Fri, 13 Sep 1996 04:00:00



I have sort of a problem configuring my lpd.  It works fine with lpr on
a single machine.  The problem is that the connected machines don't wake
up the remote lpd when lpr is called.  

  So the problem must be the printcap on the remote boxes.  After
issuing lpr on the local machine the printer starts printing the remote
jobs too.  

  Lpq tells me:

        remote printer on genesis: /dev/lp1 bad file name

  Thanks for sharing my pain with the lpd setup.

--
This mail has been composed by:
<-------------------->  / <------------------------------------>
John Reumann            \  

SET RS                  \  University of Bonn, Germany
GMD                     /
Schloss Birlinghoven    \
Germany                 /
----------------------------------------------------------------

    RSE, John Reumann, Schwarzdornweg 20, 53773 Hennef, Germany
                       fax +49 2242 85580
                     phone +49 2242 2277
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
              URL:   HTTP://borneo.gmd.de/~reumann
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

 
 
 

lpd doesn't work properly

Post by d.. » Sat, 14 Sep 1996 04:00:00




Quote:> I have sort of a problem configuring my lpd.  It works fine with lpr on
> a single machine.  The problem is that the connected machines don't wake
> up the remote lpd when lpr is called.  

>   So the problem must be the printcap on the remote boxes.  After
> issuing lpr on the local machine the printer starts printing the remote
> jobs too.  

>   Lpq tells me:

>    remote printer on genesis: /dev/lp1 bad file name

>   Thanks for sharing my pain with the lpd setup.

I assume that you are using the slackware distribution ( although after 2 years
of great luck  with SW, I would have to call 3.1 Crapware, but that's another
long sad story).

There are permission problems with the /dev directory. You need to go to
ftp.cdrom.com and get the new version of the devs.tgz in the A series and
re-install it. You can go to  the / directory and 'tar tzf wherever/devs.tgz' and
it will overwrite your /devs sub-vol. Then you will need to execute the
install/doinst.sh script.  You will need to check the  permissions in
/var/spool/lpXX also. That should fix you up.

Unfortunately by the time I found the problem, I was in no mood  to diagnose
 it down to the specific device,  but  was just happy to get it running again.
I will not be spouting the Linux gospel for awhile.

Good luck, I DO feel your pain  {8-0

 
 
 

1. 'less' command doesn't work properly in searching strings...

I got here less-205 which is a paginator better than "more".
(Works in SunOs 4.*, Ultrix, HP-UX).

Did someone compiled it for Solares2.4

The version I compiled doesnt search strings properly, any hints?


--

--- Ricky.  (Another Unix Hacker)
                                                                  \||/

| Software Engineer in R&D Dpt.                              |   / (__,,,,|
| Fibronics Ltd., Matam Industrial Park, Haifa 31905, Israel |^\/ _)

|    Fax: +972-4-313342   http://www.fibronics.co.il/~ricky/ |  / _)
+------------------------------------------------------------+  | )_)
                                                  <  >      |(,,) )__)
P.D. "Do not meddle in the affairs of dragons -    ||      /    \)___)\
      for them you are crunchy and                 | \____(      )___) )___
      go well with ketchup"                         \______(_______;;; __;;;

2. scsi detection failed slackware 7

3. 'su -c' doesn't work properly?

4. Openboot PROM monitor?

5. > ksh children won't die ; exec doesn't work properly (solution)

6. RedHat: how do I find an rpm made dir

7. ksh children won't die ; exec doesn't work properly; ksh -p

8. mkdep fails in 4.2

9. Re. bffcreate -X doesn't work Re: bffcreate -X Doesn't Work

10. PSF doesn't work properly

11. BASH doesn't seem to work properly on Solaris

12. DNS reverse address resolving doesn't work properly

13. APM suspend/resume doesn't work properly